0

Score

Avatar
Erwin Jaimes
1

Asked

My MacBook Pro 2.4 Ghz don't have sound, Airpor, Usb, screen black

History

My Laptop, do not appear to have any port available on the left side, only the power port work, and my screen goes black but it's work, if you look careful on the screen you can see that it work but of course with no light... all others functions appears to work fine, even the DVI port for additional display works fine...

This issue have relation with the envidia problem? or just be the left i/o board? I live in Venezuela, and I wish to know what I need to put my laptop to work again...

Thank you

Add Comment Cancel

Post Answer

2

Score

Avatar
mayer
296.3k
MacHale Enterprises

Answered

PermalinkHistory

To access the hard drive put it into Target Mode by hooking up to another Mac via a firewire cable and start holding the "T" key down. You hard drive icon will show up on the other macs monitor. If you can see the screen with a flashlight held at an angle the inverter is out.

Here's the inverter: MacBook Pro 15" (Models A1226/A1260) LED Driver Board

Here's how to install it: MacBook Pro 15" Core 2 Duo Models A1226 and A1260 LED Driver Board Replacement

UPDATE

Besides replacing the inverter, I would also replace the left I/O board. Here's the part: MacBook Pro 15" (Model A1260) Left I/O Board

Here's how to install it: MacBook Pro 15" Core 2 Duo Models A1226 and A1260 Left I/O Board Replacement

Edited by: mayer ( )

well... I actually can access to my laptop with external monitor attached, and everything works fine except for the sound, one USB port and Wi-Fi all in the left io board... so, the screen display problem can be caused by the left io board or it's a separated problem it self??? what do you think? Thanks Mayer...

Erwin Jaimes,

Add Comment Cancel

1

Score

Avatar
Kishore
67

Answered

PermalinkHistory

Shine flashlight into the front of LCD. If an image is being displayed. GPU (Nvidia) is fine cause image is present but backlight is not ON. Check logic board connections.

You also said external display works fine via mini-DVI port. So Logic board and Nvidia is fine.

Reseat and check that the display connections to the logic board are secure. If it is still the same I would suspect display assembly.

If still the same after display then poor or no backlight LED Driver power, faulty logic board.

Kishore... Yes, the screen has image, but backlight is not on.... and yes... I can attach an external display and the machine works fine, but the left USB port, audio line in and out, the Wi-Fi and all the sound not work at all.... and not are detected by the system.. I ran the Apple Hardware Test and it give me this error 4SNS/1/40000000 Tm0P. Do you have any idea? Thank you

Erwin Jaimes,

Add Comment Cancel

Add Your Answer

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 5

All Time: 1,970