Repair manuals for printers of many makes and models.

1843 Questions View all

Mac OS X no options or support for Zebra LP-2844 label printer?

I am having some problems with snow leopard and my Zebra LP-2844 label printer. Its a real one not a eltron or anything. It even has a built in jetdirect type networking (print over network) connection in addition to USB.

I had this working fine in Ubuntu 9.10 useing a *.ppd type driver.

I have used couple of different drivers, It prints a test page fine, Mac OS installed it, seems to know what it is, but not in the correct paper size. Can't seem to find any advanced settings. The system settings control panel won't allow me to even add a different paper size, let alone change label speed or gap space between labels? (none of the settings usually available for a nice thermal label printer are there).

pardon my spelling, and I hope this is not viewed as a rant, I just find this frustrating and have not found out much of anything searching the internet. Since I went ahead and started migrating from my Ubuntu desktop machine over to a macbook pro A1278 I didn't expect this sort of problem.

Anyone with any ideas? let me know, any advice would be appreciated of course.

I can do a dual boot with Ubuntu and OSX but seems silly to me to spend money on this laptop only to go to the trouble of installing and useing a free operating system to get my shipping needs met.

Answered! View the answer I have this problem too

Is this a good question?

Score 0


We actually have a few of these in the office, but we run them from Windows machines. I'll ask around to see if anyone has tried running them on a Mac.


helpful guide, thank you, however it does not solve my problem. I wasn't specifc enough.

There is no native support within the system preferences for printing to adjust paper handling size, feed margins etc.

Features needed to control this type of printer. Most operating systems, have this support built in, so when printing shipping labels directly from online java based scripts still doesn't work. Not without paying for some type of special program or something. So I stopped looking.

I am just going to keep using the existing system I was using, al thou it has it's problems, which I hope to resolve soon, for the type of work I am doing it seems to work the best for now.


You can print to the LP2844 using OSX with full control over the printer, at full speed and with no fuziness but you need to purchase a commercial driver.

On the LP2844 you may need to run it with a usb parallel adaptor from Sabrent as the built in USB port is a bit unreliable.

The details are here.

Hope this helps.


Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

2 Answers

Chosen Solution

Here's how to set it up:

Was this answer helpful?

Score 1


Research +


For a long time I had to boot back into system 9 to use my old Apple LaserWriter on system 10. The manufacters just don't care enough to update the old drivers. There's no money in it.


Add a comment

There is a commercial driver for Zebra printers on Mac OSX, works perfectly with the Zebra LP2844 and GK420d printer even from courier Websites and Ebay shipping. You do have to pay for it but it works.

Details are here:

Mac Thermal Driver For OSX Print Directly To Label Printers On OSX

Hope this helps people find what they need.


Was this answer helpful?

Score 0
Add a comment

Add your answer

Brian will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 11

Past 30 Days: 53

All Time: 8,774