Samsung's 5th-generation Android-based Galaxy smartphone was released April 11, 2014. Improvements to the phone include a fingerprint scanner, updated camera, larger display, and water resistance. It is available in four different colors; black, blue, white, and copper.

529 Questions View all

Can't transfer photos to PC

Ugh. I can't get my phone to transfer photos to my PC. I don't think the PC is recognizing it. I formerly used my old Samsung phone to connect easily, using Verizon Cloud, and transferred no prob. Why does this phone not connect? HELP

Answered! View the answer I have this problem too

Is this a good question?

Score 20


I had this same problem. Nothing worked for me until I copied all my gallery photos and then pasted them into the DCIM folder located in my micro SD card, which allowed me to view and transfer whichever photos I desired. The "Developer" option did not work for me.


Have your try another USB cable? Update driver, enter MTP mode. Or you can try Google Photos app to wirelessly copy photos from galaxy s5 to pc.


I have a Galaxy J3 not the s5. Can I still down load as you said MPT ?


Add a comment

4 Answers

Chosen Solution

Are you on the latest Android Version called 6.0 / Marshmallow? When you plug your phone to your computer via MicroUSB / USB 3 cable you need to drag down from the notification bar / status bar then select the tile called 'USB for charging, Touch for more options' then select 'File transfers' for the Use USB for window dialog.

This should then allow you to access the files on the PC.

f that still doesn't work then you will need to go to phone settings, scroll down to About Phone, then tap on that, then tap on build number 7 times and it will show the developer options where you need to go back to the settings list to select it. Once you get in developer options scroll down and look for Enable USB debugging. Enable that and see if that works.

Other wise you may need to go into storage under phone settings then press the menu button, usually the 3 dotted menu button on the top right of the screen and change the USB connection settings there.

Still having issues? Look at the comments right below my answer for another solution.

Was this answer helpful?

Score 27


I had the same problem with my Samsung Galaxy and I followed your debugger instructions however there was one more step. After you go back to settings, select Enable USB debugging keep scrolling down till you get to USB Configuration, tap on that, select PTP Picture Transfer Protocol, then plug your phone into your computer and you will now see an icon that looks like a storage device, click on that and you will see all the files on your phone. Once you unplug your phone the USB config will revert back to USB Charging.


i had one extra step.


about device

build number (7x)

...... go back to settings....

developer options

USB debugging - select - turn on

....scroll down ...

USB configuration - press and hold to get pop up - radio buttons MTP = media transfer protocol

a couple of notes


2. if USB debugging already enabled. ---the above, then you get a message when you tap 7x t get message "already enabled. "

you will have to reactivate

....USB configuration - press and hold to get pop up - radio buttons MTP = media transfer protocol


Thanks for the simplified steps I will reference your comment in answer.


Or, just set up google Photos then go to the website.

Also, USB debuging isn't necessary to transfer between an Android phone and computer. Just plug it in select photo transfer from the notification bar.


I have a simpler solution for those that aren't Geeks. If i connect my phone to pc it detects it (on the phone i have to give permission to the pc to read files etc you click yes ) then when you open the photo folder you only see Screenshots. so select all photo's you want to transfer (on your phone) tap the triple dot copy or transfer files to album select screenshots & your done.

Just remember that if you copy a lot your phone's that you have enough free MB


Show 6 more comments

Add a comment

I had this same problem. Samsung and AT&T offered me no solutions that worked. The "Developer" option did not work for me. Installing Samsung Smart Switch did not help. Installing the driver did not help. Installing Samsung developer software did not help. Nothing worked for me until I had a sudden bout of common sense and copied all my gallery photos and then pasted them into the SD card's DCIM Camera folder, which allowed me to view and transfer whichever photos I desired.

Was this answer helpful?

Score 0


How do you do that?


Add a comment

I have an additional question....once I do all these steps, my phone wants to transfer ALL (and there are a ton) of the pictures from my son's tooth brushing app and a bunch of random pictures that look like they might have come from Instagram, but aren't pictures I posted on Insta. Is there a way to make it so that it only transfers the pictures from my gallery and not all these other random pictures? It's super time consuming to go through over 2,000 pictures to only pick out the 200-300 I really want to transfer.

Was this answer helpful?

Score 0
Add a comment

My computer recognized the cell phone, however the Samsung folder on the computer was blank and it did not show ANYTHING, including all files, pictures, etc. ~ so after searching on the internet, here's what I figured out and it worked although I am computer illiterate. After doing this, it enabled the Samsung folder and I can now view and transfer photos, files, etc. from cell phone to the laptop.


  • Go to Settings
  • Tap on "Developer Options"

{if Developer Options is not turned on, hit it 7-times and that will turn it on}

  • Scroll down to Networking Section and Tap on "USB configuration"
  • Tap or turn on "MTP (Media Transfer Protocol)"

{a window will pops up that says Allow access to phone data}

  • Tap on "Allow"

. . . . . and there you have it!

Was this answer helpful?

Score -1


After I turned on Developer Options, I cannot find "Networking Section" or "USB Configuration". Any ideas?


After I tapped on MTP, no window popped up to allow access to phone data. What should I do?


Same here. Nothing "popped" for me either.


Add a comment

Add your answer

lichencraig will be eternally grateful.
View Statistics:

Past 24 Hours: 155

Past 7 Days: 1,510

Past 30 Days: 7,182

All Time: 102,807