An easy to use home Espresso machine created by Saeco and rebranded for Starbucks. This machine is excellent for every day espresso drinkers and has an excellent build and product life.

126 Questions View all

Pump works, briefly, then gets quieter, doesn't pump

When I start to pull a shot, everything sounds normal, works normally. Then the pump gets very quiet and stops pushing water through the coffee. To me it seems as if a valve gets shut, but the pump is still trying to pump. If I turn it off, then on again, it works briefly, then gets backed up (or loses pressure?) again.

It works fine without the Portafilter in place. It works with an empty PF - but it leaks out the top so much that the pump isn't really being challenged.

All screens are clean, and I've tried single shot pods (my norm) and double shot with Starbucks ground espresso, loosely tamped.

Thanks for your help!!

Answer this question I have this problem too

Is this a good question?

Score 2
Add a comment

2 Answers

Most Helpful Answer

If water flows through the portafilter when there's no coffee in it then it's very likely your pump is failing and needs to be replaced. That's assuming nothing is leaking while it's running (ie. the steam wand).

Was this answer helpful?

Score 3

Comments:

Thanks so much, Henry H, I really appreciate your help.

by

Here's a twist, though: it seems kind of like the pump gets quiet because the portafilter is holding back the pressure, maybe not because the pump is weak. Is that possible, that it would let the coffee flow intermittently, the portafilter valve opening and closing?? Thanks, again!

by

If water flows through the portafilter when there's no coffee in it then the portafilter itself is probably fine. If the portafilter valve were clogged shut or assembled incorrectly, or if the coffee basket were clogged, then you wouldn't be able to get anything through. Since you're using pods it's unlikely that the coffee itself is an issue (ie. too finely ground or tamped too hard), and that leaves only the pump as a possible source of the problem.

by

Michael, did you get your machine working? I have the exact same problem with my machine. The pump turns on, fills the portofilter bowl with water, then quiets and doesn't move water. Steam wand still works. Everything seems operational. I disassembled and cleaned grounds bowl, portofilter, and the brewhead screen. Water comes out of the brewhead, shoots through the screen, but with the portofilter in there, it refuses to push the water through. Any suggestions?

by

Nembry, I think Henry H is right, and we have pump problems. That said I did get mine to work, but only when using pods - not loose grounds.

I ran a needle into each and every hole in the grounds bowls (I put tape on the top to save my fingers). At the time it seemed like I was maybe even making the holes larger than they were originally, but I can't be sure.

So that worked for the pods (I also cleaned everything else you mentioned), but loose grounds still won't flow. I even tried not-packing them, leaving lots of room, and nothing.

I was ready to buy a new pump one day when I saw a posting that the pumps can often be fixed! So, that process has stalled till I get the inspiration to try it :)

Henry H, if you see this, can pumps be fixed, sometimes?

Good luck, Nembry

by

Show 1 more comment

Add a comment

I've had the same problem with my unit; sometimes a quick on/off of the steam wand fixes it for me. I took my unit apart and the pump *seemed* okay, but it's hard to tell when it's inconsistent. I think Henry's probably right though.

I think this may be the correct pump- I'd check with yours to make sure though. http://www.amazon.com/dp/B00B8KBVZE/ref=...

Was this answer helpful?

Score 0

Comments:

The EX5 will work but you can use the cheaper EAP5 instead; same flow rating, but a plastic stem instead of metal.

by

Add a comment

Add your answer

Michael will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 4

Past 30 Days: 16

All Time: 337