Why won't my mac power up?

Hello,

My MacBook Pro will not power up. Here's the story of what has happened so far.

My battery had the status of SERVICE BATTERY SOON. Then changed to REPLACE NOW. I didn't know it had changed and my computer unexpectedly shut off. It was able to turn on again multiple times, but wouldn't remain on. After a while it just stayed dead. Keep in mind that my power adapter was frayed. I assumed since I saw the warning just days before that it was my battery. I bought a new one and it worked right away. My computer turned straight back on and had about 45%. I plugged it in to charge it, but my computer wasn't recognizing that one was even plugged in. Eventually the battery died and the same thing happened as before. Now there was no indicator light from my power adapter, so I bought a new one of those as well.

So now my computer has a new 85w power adapter and a brand new battery. Still won't start up... At first when I plugged in the new adapter it had a faint green light. After some trouble shooting it now displays a fully lit green light. Still won't turn on. I wen't through and tried many troubling shooting.

- I reset PRAM

- I reset SMC

- I removed the battery and plugged the power chord in... Nothing

- I removed the power cord, held the PWR button for 10 sec, plugged the MagSafe connector in, continued holding the PWR button for another 10 sec, released the PWR button and immediately pressed the PWR button again... Nothing

- I removed my RAM cards individually to see if one was bad... Nothing

- I checked my Logic Board for corrosion/ water damage. Everything looks fine. Just a little dusty.

Now here is where I had some false hope. I had the battery removed and was attempting The PWR cycle again. Once It completed I noticed a very faint ticking sound. I later discover that my fan was the one ticking. I went to flip my computer over then all of a sudden it booted up! The fans were at 100%. I let it completely start up and everything was working fine with NO battery installed. I closed my computer to let it sleep and reopened it 20 or so min later. The fans were normal at this point. It came right back on and was working fine again. Still NO battery installed. So I thought what ever was wrong was fixed, but it then powered down again while I was using it. It did restart after that though. I thought I should try and put the battery back in and try it again. I shut down the computer properly and unplugged the MagSafe. I reinstalled the battery and closed the case. After plugging the MagSafe back in the light turned green. I went to power up and guess what...NOTHING!

I tried doing the PWR cycle, PRAM, SMC again and it still won't turn on. Although the faint clicking from the fan still happens. Here is what I have determined. Correct me if any of these could still be the issue.

Battery - Brand New

MagSafe Power Adapter - Brand new 85w

MagSafe DC- IN Board - Could still be it, unlikely since it powered up once and the fan clicks?

Outlets - Tried multiple ones, same result on all.

Fans - Clicking when trying to power up. Can they cause a start up failure?

RAM - Tested each one individually, no difference.

HDD - Unlikely since it started up once and had no problems opening/ closing files.

Logic Board - Possible? (I hope not) When it started up all functions worked. (Fans, volume control, screen, etc.)

I feel like i've tried everything and I still have no sure solution to what is causing the problem. I would love it if it was something I can repair on my own. I think I will buy another battery and a MagSafe DC board and see if I can at least get it to turn on again to do safe mode/disk analysis/ repair/ reinstall OS. whatever works really.

Thanks for reading! Hope you genesis have a solution for me too! I've learned all of this from this community alone.

UPDATE:

I had it opened and plugged in and it started up on its own. The fan went to 100%, no display, and the computer beeped three times. Doesn't that mean my RAM is bad?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Turned out to be the DC-Board. I changed it as well as my RAM and it works and is charging! I also cleaned my Logic board with a soft bristle brush.

Was this answer helpful?

Score 0

Comments:

I am happy to hear you got your computer working Kyle.

by

Add a comment
Most Helpful Answer

Hi Kyle; you have been very thorough; but i have one question. Did you use an ESD Strap of any kind during your repairs? It is possible you might have a dead RAM; which might be caused by ESD. I have a similar situation where i actually fixed the "main" problem but created another by frying my memory modules since they are very susceptible to ESD; i hope this helps.

Was this answer helpful?

Score 1

Comments:

I honestly didn't know what a ESD strap was. All the videos I watched didn't use one. I did everything on a blanket and was standing on carpet. I never got shocked when doing anything. It is still possible I guess. Thank you for your response! I really appreciate it. Also I should add I tried to turn it on again without the battery this morning and it started to boot up. It clicked off almost immediately though.

by

Add a comment

Add your answer

Kyle will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 81