Mag Charger cable blinks green w/o the Battery

Well, I have a problem. I've changed the Mag DC Board and the battery still wouldn't charge. The led lite on the charger cable wouldn't turn on. When I remove the battery the led lite blinks a dim green. But the MB won't turn on. Once I insert the battery it stop, the led lite shut off and the it won't charge. Any clues or ideas? I'm going to clean up the battery connector and try again, but if you do have some helpful tips. I'm all for them.

First, it's has the proper MagSafe watts, even if I put the a higher watts, the MagSafe Dc Board calibrates the watts.

Second, the charger works fine with other MB/MBP. Plus i've took the charger to the AppleStore to have it tested. Battery is new.

Third, I've replace it cause I spilled soda, and i manage to clean it up. Everything on MB works fine for the exception that it doesn't charge. that's the reason why I replaced the DC Board.

On another note under systems profile, power the battery info is there but under ac plug it say no and on charging it say no, too.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Certain you have the proper wattage MagSafe charger?

by

Does the computer work with a different charger? or does the charger work with a different computer?

by

also- how's your battery health?

by

Why did you replace the DC Board to begin with?

by

Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Chosen Solution

Bad Charger

Apple says: Symptoms

Is your portable computer's MagSafe power adapter not working correctly? This article will tell you what you can do if you experience one or more of the following issues:

  • Your power adapter won't charge the computer.
  • The LED on the adapter connector doesn't light up when attached to the computer.
  • The adapter only charges the computer intermittently.

So the charger should always light up battery or no, orange when charging, green when charged, or if no battery is present.

Sounds like a short developing in the cable or charger. . . this may have blown your original DC in board.

If this answer was helpful please remember to mark it accepted.

Good Luck,

N

Was this answer helpful?

Score 1
Add a comment

Hello people.

I'm in a similar situation: my MB didn't boot anymore. Whether on battery or on MagSafe, it doesn't power on.

I managed to change the DC-In board, but still doesn't power on. MagSafe is working OK because it's from an other MB.

What's the next step I should take? Is the MoBo TFU?

Thanks and kind regards,

Flavio.

Was this answer helpful?

Score 0

Comments:

Please start your own question. Thanks

by

Add a comment

Add your answer

Eazy will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 2,748