Atheros AR9285 Wireless Network Adapter stops working

I have been having a problem with my internet connection recently. Every once and awhile, I will suddenly lose connection to the network I am connected to. When I go to connect to it again, my network doesn't appear on the list. A few seconds after this, all of the networks on the list will disappear. I tried using the troubleshooter to fix the problem, sometimes it will tell me that my adapter has been disabled, and re enables it. More recently however, it cannot find the solution to the problem, and the only way I can fix it is by restarting the computer. I am not the best with computers, and I do not understand how my drivers work, but I have figured out that my Atheros AR9285 Wireless Network Adapter is the main issue. I have tried uninstalling my drivers and restarting, but that hasn't helped. I have seen other people online with the same exact issue, but they haven't figured out a solution. The problem can be very annoying, and I don't want a short term solution.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

i had the same issue with the Atheros 9285 on my Fujitsu Lifebook . After 3 weeks of trouble now i have a new one from Intel. No connection errors more , works absolutly fine.

http://www.amazon.de/Intel-Mini-PCIe-Net...

Was this answer helpful?

Score 0
Add a comment

Add your answer

Spyblox007 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 22

All Time: 395