The March 2015 update of Apple's 13" MacBook Pro Retina Display, model A1502, features fifth-generation Intel Core i5 and i7 processors and introduces the Force Touch trackpad.

245 Questions View all

Unable to power on after SMC reset

Hi,

I have been having some problems with my Macbook Pro for the last month or so. Initially it wouldnt recognise any external USB mass media connected to a USB port unless I reset the SMC controller before connecting it which was a pain.

After about a week or so, without my intervention, it seemed to sort itself out but then I started having another problem in that the keyboard and trackpad would stop responding. This could be during normal use, after a reboot etc. It seemed totally random and I couldnt predict when it would happen. On those times that it did, if I connected an external keyboard and mouse, I could continue to use the computer, just the internal devices wouldnt work.

It happened again yesterday while I was watching a move, so I decided that I would try a clean install of the OS (google searches seemed split as to whether it was hardware or software and there were some errors in the console that suggested it might be driver related).

I backed up and then I rebooted the computer however after the reboot the computer would no longer power on. Nothing happens when I press the power button at all. I have tried an SMC reset and I can see a change in the diode on the charger, so I can see that the SMC has reset but afterwards it still doesnt work.

Ive tried disconnecting and reconnecting the battery and disconnecting and reseating the IO controller but no change at all.

Incidentally even though the battery is fully charged, the charger light is orange and stays that way constantly. Ive found articles online for what to do when its blinking but cant find anything for when its constantly orange that would be useful.

It seems it might be the logic board? What do you think? Anyone have any ideas? Im in a country without an official Apple store, so my options are to do it myself (which I dont mind) or take it to an authorised reseller who will have a month to work on it (which I dont like as it has my data on it, I didnt get to wipe it).

Thanks in advance for your help.

p.s. no water damage, nothing spilt on it, it wasnt dropped etc and its out of warranty.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

First I would still try going to an Apple Store near you to see if they have any outstanding recalls.

I suspect you either have a bad CPU or the charging logic is damage here. Is your MagSafe adapter cable worn or blistered? If it is that could have been the cause. A short in the cable can damage the charging logic and the power rails. I would at least pick up a new charger before going to apple ;-} if it's looking ratty.

But before you go you could take your SSD drive out and put it into an external case to either copy off your data as well as wipe it down using a second Mac system. Here's the needed case: OWC Envoy Pro.

Even if Apple doesn't have any outstanding recalls. The Apple bench rate will be the cheapest repair.

Was this answer helpful?

Score 3
Add a comment

Add your answer

Elizabeth Proudlove will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 17

All Time: 453