Model A1502 / 2.4, 2.6, or 2.8 GHz dual-core Intel processor / Released October 2013

275 Questions View all

water spill- Chip 33 1ESO has no voltage

Hi, would really appreciate the help. I had spilt coffee onto the keyboard of the laptop and somehow managed to revive it by cleaning out the boards. It never worked perfectly after that. At time it would work normally but at other times it would not recognise the battery. Anyway, it now only works when the charger gets plugged in but it is slow. I ran a test on the logic board and CHIP 33 1eso has no voltage at all. The others appear to be OK. Can someone tell me what this chip is and what are the values? 33uf 16volts? Can I replace it with another type of chip as i doubt I can find the same one. Thanks very much.

Update (03/25/2016)

Block Image

This is the chip I am refering to. Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Thanks very much for your answer. Really appreciate this. I live in Singapore and will visit the electronic stores on Monday to try and hunt down the chip, sorry, capacitor.

by

Here is the picture I said I would try and post

by

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

@larrysolberg sorry that is not a "CHIP". It is a simple 33uF 25V 10% Poly-Tant capacitor in a Case D3L package. It is part of your 15V boost regulator circuitry. Depending on where you life I'd try places like mouser.com or digikey.com as well as many others.

Was this answer helpful?

Score 3
Add a comment

Add your answer

lars will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 149