Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1378 Questions View all

Will not power on, no video, no sound, no fans?

So yeah. A couple months ago I dropped my MacBook and it hasn't worked since. I had some free time so I decided to investigate the issue.

I have taken the top case off to look for any obvious damage, but as far as I know the logic board is fine, no loose wires or any breakages anywhere as far as I can see. I have noticed if I plug the AC power in I hear a tinny popping sound from the logic board...I assume that isn't normal? Like a blown capacitor or something like that?

Oh, the battery won't charge, and yes I've tried resetting the SMC and all that stuff.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Chosen Solution

MagSafe LED ON, indicates power flowing to logic board. So:

Reseat the keyboard flex cable to logic board. A disconnected keyboard or a stuck/open power-on key can disable system powering on.

If power button does not work, use jeweler’s flatblade screwdriver to short the Power On pads on logic board to power up the logic board.

If power-on key is stuck, keyboard flex cable might need to be disconnected before shorting pads. Verify that system powers on.

Replace top case for stuck power-on key.

If shorting does not help, Remove logic board and verify that the MagSafe connector is correctly connected underneath logic board and Reseat MagSafe connector on logic board and retest.

Was this answer helpful?

Score 1

Comments:

Still nothing on that..and before I try to remove the logic board, what about the small popping noise I hear that I mentioned? Wouldn't that be a dead or dying capacitor somewhere? I'm not sure how I could isolate that...

by

Add a comment
Most Helpful Answer

I think Kishore's advice is good. I think you probably have a fried board. But the one thing I would add is to re-seat the RAM, and test the RAM slots one at a time by leaving one slot empty, and then the other. With the laptop off but connected to AC power, hold down the power button for about 15 seconds, and see if that wakes it up. Do this after every memory re-configuration. Good luck!

Also, I'd try a friend's AC adapter, just on the off chance that yours is bad and causing the issues. I'd try a different power outlet as well.

Was this answer helpful?

Score 2

Comments:

Add a comment

Verify AC power presence with MagSafe LED indicating on, or in charge state. Try booting unit only with AC adapter and with out the battery.

Inspect unit’s AC adapter and verify that cable and MagSafe connector have no damage.

Reset SMC.

Reseat battery connector and retest. If physical damages are found, replace damaged parts and retest.

Unit’s battery may be run down, or not recognized. Substitute unit’s battery with a known-good one to verify that system starts on battery. Else the issue may be with the Logic Board.

Was this answer helpful?

Score 0

Comments:

The MagSafe LED turns on. I have in fact tried with ONLY the AC adapter, no success.

As far as I can tell, the AC adapter still works fine.

I have tried to reset SMC.

I have no tried reseating the battery connector yet..

Dunno about the battery.

by

I don't think reseating the RAM would do anything...The computer doesn't do ANYTHING at ALL when the power button is pressed. Fans don't spin up, light doesn't turn on, no reaction at all.

I will try to use a different AC adapter when I can, unfortunately all my friends own nothing but PCs...

by

Add a comment

Add your answer

Joshua will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,495