Android tablet released in September of 2014. Lenovo Tab S8-50F

25 Questions View all

My tablet won't turn on.

Yesterday it was working fine. Charged overnight and now....nothing. I tried looking for the hard reset button behind the SD cover, but can't find it. Anyone have a picture of it so I know what i'm looking for?

Otherwise, other suggestions? I tried holding the power button for 20 secs with AC plugged in/AC not plugged it. I tried holding power + VolDown. I tried pretty much all combos of buttons. Nothing.

It's possible the charging port stopped working and the battery is dead, but I don't know how to test that.

Help?

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

My Lenovo TAB S8-50LC was working just fine a while ago and it suddenly turned off and I can turn it on again. It just vibrates for just 2-3 seconds and nothing happens. Can anyone has an answer in my problem in my Lenovo TAB S8-50LC. Pretty please.

by

Add a comment

2 Answers

Most Helpful Answer

Hi Karin,

You can find the following directions for the hard reset on this troubleshooting page.

"To reset, make sure that the tablet is turned off completely. Then turn on the device by holding both the volume up and power button simultaneously. This will show the recovery menu. Select Wipe data/factory reset (this will delete all data from the device, such as music and photos). Press the volume up button to confirm. Wait for the reset to be finished, then select reboot and press the power button to restart the device.

Warning : A factory hard reset will erase all data such as photos and apps from the device."

I would also try charging the tablet from a different outlet. If that doesn't work, try charging the tablet with a different charger. If the tablet charges, then you know the original charger is the problem . If not, then you could look to the charging port or the battery as the possible culprit. Troubleshooting tablets can be a tedious process of elimination, but you're on the right track! Good luck!

Was this answer helpful?

Score 1

Comments:

@kelsea Please expand your profile so we can get to know you better and what you do. You answer questions well, but we need to be able to chide and harass you in case you drop the ball ;-)

by

@mayer You got it ! Profile expansion is underway.

by

@kelsea Thank you for you reply. As I mentioned, I did try the power button + Vol UP (as well as all other combos). Nothing is happening with any button combo. So a reset is not possible.

I know there's a paperclip hole somewhere, but I can't find it.

I will try another charger, though I've tried 2 already. Maybe it's the charging port that went on the fritz? How do I check that??

by

@kelsea Nope, charging it with a different charger doesn't work. Do I need to replace the charging port to see if that's the issue? Any good links for how to DIY? Any other diagnostics I can try?

I'm really good at Googling, and have found a couple tutorials for replacing the port, but I'm not sure which are the best.

And I haven't found anything that tells me how to diagnose it further while it's still a brick. Thus asking the questions here. Thanks!

by

Add a comment

Did you ever figure out a solution? I'm having the same issue with my Lenovo S8-50 tablet - won't charge, won't turn on. I'm not sure if you've tried this yet, but I actually tried plugging the tablet into my laptop's USB port and windows told me there was a power surge on the USB port. At that point, my wireless USB mouse stopped working at well, which makes me think Windows just disables all USB devices when something like that happens. I think it also might be an indicator that the USB port on the tablet is shorted out so it's trying to draw too much current. Anyhow, I think the solution might be to replace the tablet's USB port.

Was this answer helpful?

Score 0
Add a comment

Add your answer

karin will be eternally grateful.
View Statistics:

Past 24 Hours: 7

Past 7 Days: 48

Past 30 Days: 206

All Time: 4,291