itunes error (50) when in recovery mode

Hello I got an Iphone 5C model A1507 ! It hard some searching issues, but i dirent pays too much attention to it thinking it was my network provider's fault! I changed the screen that had a crack! And when I did assemble everything, I got stucked on apple logo, so I connect it to iTunes, and it asked me to restore it!

When I tried to restore it, it restores to 75% and then stops and says "this iphone could not be restored, error (50) occured" on Mac, and the same occurs on Windows but with error (1).I went to few forums, tried all the first safety steps, but nothing solved my problem!

So I was wondering, is it software or is it hardware related?

I dismantle it to clean the logic board with isopropyl to see if I could get some results!Nothing changed!

So I went to few more forums, and found out that it was related mostly to the logic board, mostly because possibility of unsoldered chip baseband (responsible for the network signal)! It says also it could be the SIM card reader, but most of the time, it is more often linked to the baseband chip! The problem is that kind of soldering is called micro-soldering , and it's not any shop next door, that can do that, you need proper equipment to do that!

So my question is simple, does someone knows addresses of shops doing this kind of works, from reliable sources?

(Updated with I hope correct syntax, sorry I am French and I typed it from my iPad)

Answer this question I have this problem too

Is this a good question?

Score 2
Add a comment