Model A1181: 1.83, 2, 2.1, 2.13, 2.16, 2.2, or 2.4 GHz Core 2 Duo processor

1378 Questions View all

Won't power on, replaced DC-in, topcase, RAM, etc.

Hello! I've got a 2.4GHZ white MacBook which will not power on. Absolutely nothing happens when you try. I've replaced the DC-in, topcase, RAM (I tested both slots) and AC with known-good parts. The DC-in shows a solid green light, but there is no other sign of life. I've tried resetting PMU/PRAM, but it doesn't even do enough for that to matter.

To me, this means the board is dead, and this is where my abilities drop off and I pretty much give up. It's not under warranty, and it does not appear to have water damage. My question is, can anyone think of additional troubleshooting steps to take? If not, are there entry-level logic board repair steps that I could pursue? People buy dead machines like this all day from me on eBay, so I know there must be ways to repair dead boards. If anyone has ideas, I'd appreciate it.

Thanks!

Answer this question I have this problem too

Is this a good question?

Score 3
Add a comment

1 Answer

Most Helpful Answer

maybe a crazy idea, but have you tried disconnecting the PRAM battery?

I have NO idea if this will matter for this model machine (I'm guessing "no"), but I do know that the old PowerBook G3 Pismo if left unused for a long time would sometimes appear totally dead - no effort to get it to power up would result in any sign of life. I had this happen to my 9yr old Pismo when I took it out to try using again after a couple years of non-use. After finding a tip about this problem, I unplugged the PRAM battery for a few minutes then plugged it back in - then pressing the power button brought it back to life. I guess the PRAM was stuck in some weird state.

probably a long shot, but thought I'd mention it. good luck

Was this answer helpful?

Score 2

Comments:

Awesome, that's the kind of idea I'm looking for! I just checked, and unfortunately the PRAM battery is on the underside of the motherboard. Maybe this weekend I'll take it apart and see if that does anything. Thanks!

by

you're welcome! - hope it helps, I'll keep my fingers crossed for you :)

by

Add a comment

Add your answer

rdklinc will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 2,666