Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

475 Questions View all

Why does my computer freeze waking up from hibernation?

My MBP has had this problem since freshly escaping from it's cardboard prison (13", 2.4 GHz, late 2011). About 90% of the time it doesn't want to wake up from hibernation. When it does fail, sometimes the progress bar (that appears waking up from hibernation) will fill up all the way and the laptop will automatically restart, at other times the progress bar will only fill up partially and the laptop will freeze.

I've already tried resetting the SMC, PRAM, deleting the sleep file, fresh installing El Capitan, replacing the memory and messing with the hard drives. Whenever I hibernate it 30 seconds after booting, it'll wake up fine. I did my research trying to find a solution but none have worked so far. I was hoping somebody can give me specific help for the panic report I've included below. One piece of information that might be useful is that, for testing purposes, I have pmset hibernatemode set at 25.

A list of events in the console around the hibernation-wake-failure and the panic reports are included below.

Thanks in advance! Let me know if any other information will help!

System Specification (from end of Panic Report)

Model: MacBookPro8,1, BootROM MBP81.0047.B2C, 2 processors, Intel Core i5, 2.4 GHz, 16 GB, SMC 1.68f99

Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In

Memory Module: BANK 0/DIMM0, 8 GB, DDR3, 1333 MHz, 0x8502, 0x505344333847313333333253000000000000

Memory Module: BANK 1/DIMM0, 8 GB, DDR3, 1333 MHz, 0x8502, 0x505344333847313333333253000000000000

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (

Bluetooth: Version 4.4.3f4 16616, 3 services, 27 devices, 1 incoming serial ports

Network Service: Wi-Fi, AirPort, en1

Serial ATA Device: INTEL SSDSC2CW180A3, 180.05 GB

Serial ATA Device: ST9500325ASG, 500.11 GB

USB Device: USB 2.0 Bus

USB Device: Hub

USB Device: IR Receiver

USB Device: USB 2.0 Bus

USB Device: FaceTime HD Camera (Built-in)

USB Device: Hub

USB Device: Apple Internal Keyboard / Trackpad

USB Device: BRCM2070 Hub

USB Device: Bluetooth USB Host Controller

Thunderbolt Bus: MacBook Pro, Apple Inc., 22.1

Console Events around Failure (events after reboot started at 10:29:41, before that was hibernation)

Panic Report

Anonymous UUID: 0304991E-D3F6-74AC-1F51-DFE32A8E0A1D

Thu Feb 25 22:29:51 2016

  • Panic Report ***

panic(cpu 0 caller 0xffffff8021c7f068): "Hibernate restore error e00002eb"@/Library/Caches/

Backtrace (CPU 0), Frame : Return Address

0xffffff820a5d3b10 : 0xffffff80216df792

0xffffff820a5d3b90 : 0xffffff8021c7f068

0xffffff820a5d3c60 : 0xffffff80217df1fa

0xffffff820a5d3cd0 : 0xffffff7fa41dd52d

0xffffff820a5d3d10 : 0xffffff7fa41e0d79

0xffffff820a5d3d30 : 0xffffff8021cd38ff

0xffffff820a5d3d90 : 0xffffff8021cfe9e6

0xffffff820a5d3e00 : 0xffffff8021ca48f9

0xffffff820a5d3e60 : 0xffffff8021c9c884

0xffffff820a5d3ec0 : 0xffffff8021ca9b42

0xffffff820a5d3f00 : 0xffffff8021ca9c92

0xffffff820a5d3f40 : 0xffffff8021cb4d61

0xffffff820a5d3f80 : 0xffffff8021cb4f5c

0xffffff820a5d3fb0 : 0xffffff80217ccf77

Kernel Extensions in backtrace:[3BE4E926-E063-3BBD-BE05-F6F97358C7A4]@0xffffff7fa41d2000->0xffffff7fa4231fff



BSD process name corresponding to current thread: kernel_task

Mac OS version:


Kernel version:

Darwin Kernel Version 15.3.0: Thu Dec 10 18:40:58 PST 2015; root:xnu-3248.30.4~1/RELEASE_X86_64

Kernel UUID: DECC9F02-27D7-31F0-9599-A9EF2873902C

Kernel slide: 0x0000000021400000

Kernel text base: 0xffffff8021600000

__HIB text base: 0xffffff8021500000

System model name: MacBookPro8,1 (Mac-94245B3640C91C81)

System uptime in nanoseconds: 894452448417

last loaded kext at 7242957191: 1.70 (addr 0xffffff7fa3901000, size 32768)

last unloaded kext at 108398222874: 1.0.1 (addr 0xffffff7fa26b2000, size 126976)

loaded kexts: 1.70 3.0 1.9.5d0 110.20.22 1 124 3.12.6 3.6.1 272.51.3 1 1.0.1 272.51.3 10.0.0 4.4.3f4 170.8.8 7.0.0 1 4.4.3f4 1.0.0 10.0.0 208 3.0.8 3.1 4.0.0 1.2.13 1.0.0 3.0.4d1 245.4 245.4 327.5 1.0.0d1 1.0.0 38 5.5.2 2.8.5 800.20.24 1.7.0 10.1.12 3.1.8 1.0.1 2.0 161.0.0 4.0 1.8 2.1 4.0 1.7 218.0.0 163 3 8 218.0.0 1.0 3.12.6 272.51.3 525 108.0.1 11 1 4.4.3f4 4.4.3f4 1.0.14d1 2.2.6 272.51.3 272.51.3 204.3 1.2.0 1.1.0 2.4.1 3.12.6 1.0.0 1.0.14d1 2.4.1 1.0.0 6.0.0d7 3.1.9 3.7.7 250.5 900.4.1 1.0.1 1.0.1 4.1.3 4.1.3 2.0.2 4.5.8 4.0.4 5.1.0 1110.26 1.0.4 1.0.3b3 1.0.1b8 3.2 900.4.1 2.8.1 1.0.1 1.0.1 1.0.1 2.0 2.0 2.0.0 1.1 300.0 1.0.0d1 2 1.0.5 1.0 417.2 2.1 31 28.30 4.0 2.9 1.4 1 1 1.0

Answered! View the answer I have this problem too

Is this a good question?

Score 0


You speak of multiple drives, what do you have here and which drive is set as the boot drive?


hello, the problem persists even if the hdd settings you do not ever go to sleep?


There is an HDD in the optibay, and an SDD in the main drive bay. The SDD is the boot disk. Before the SDD was installed, this problem happened with the HDD in the main bay and a cd-rom in the optibay.

I have also tried unchecking "put hard disks to sleep when possible," but same problem.


what is the solution with my MacBookpro


Hi, i add the same problem on my macbook and the same configuration. One of my 8gb ram was half dead. Try to change one after the other, to find which one is not working properly.


Show 1 more comment

Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

2 Answers

Chosen Solution

Lets start things off by making sure the systems firmware is up to date. Follow this Apple T/N: About EFI and SMC firmware updates for Intel-based Mac computers make sure you are at least at the level listed or newer.

Update (02/26/2016)

At this point I would suspect the SATA & Sleep sensor cable is having a problem. Here is the IFIXIT guide to replace it: MacBook Pro 13" Unibody Late 2011 Hard Drive Cable Replacement. Maybe in the process of installing the SSD you nicked the cable damaging the Hall effect sensor connection. Make sure you use the newer rev of the cable as I suspect you have a SATA III (6.0 Gb/s) SSD here. The older cable is only rated for SATA II (3.0 Gb/s) drives.

Update (02/27/2016)

Wow! You've gone almost all of the way in swapping things out ;-} Which is the best way to isolate this out without getting deep into the circuitry.

Just so you know there is no sleep sensor on the battery tester just a normal power transistor which looks similar to the Hall effect transistor (similar package).

OK, sadly, it's looking like the SATA ribbon cable connector on the logic board and/or the logic on the logic board is the issue here.

Did you get your system wet at some point? Your problem is so rare I can only think something is shorted out by some corrosion. Do a through inspection on both sides, are any of the moisture sensors red? Or do you see any corrosion?

If not its time for a new logic board or ship your logic board to someone with the deeper skills to repair your logic board. Sadly, if this was a problem when new it would have been covered under warranty. It's too late now.

Was this answer helpful?

Score 2


It looks like they are updated. The site says "MBP81.0047.2AB" as the latest, and I have "MBP81.0047.B2C." The site says "If you don't see a firmware version listed in this article, it means that either a firmware update is only available as an automatic update, or no firmware update is needed." So I'm assuming B2C was an automatic update and came after 2AB (2AB is only installable on Maverick, and B2C installed with El Capitan as per my Google searches).


Thank you for the help, Dan! Knowing about that cable will help me tremendously. My concern is that I was having this problem before installing the SSD. Could it still be the problem? Would I be able to see if the cable is damaged through a visual inspection?


It's hard to say. Sometimes you have to sling the spaghetti at the wall and see if it sticks ;-)

The other way you could test this is using a magnet pressed against the uppercase where the sensor is (on the keyboard side) and you could also check to make sure the magnet is correctly anchored in the lid by sliding a paper clip along the glass of the display panel again where the sensor is located.


Could it have something to do with the Bluetooth/AirPort cable? That one is definitely damaged. Should I try throwing that one against the wall first?


Try just unplugging it for now (put a small piece of tape over the connector). Did that help?


Show 5 more comments

Add a comment

the problem started, I sent my MacBook pro to shutdown and my WIFI was off then before shutdown I immediately touch the WIFI to ON and my MacBook shutdown then next day when I started it will staring as normal and it was february until now is the same.

Was this answer helpful?

Score 0
Add a comment

Add your answer

jeebster will be eternally grateful.
View Statistics:

Past 24 Hours: 4

Past 7 Days: 42

Past 30 Days: 219

All Time: 11,005