Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

389 Questions View all

MacBook battery doesn't work after RAM upgrade, no chime

I just followed the guide for replace my MacBook Pro RAM from 4GB to 8GB (one chip), when I reconnected the battary it won't work and my Mac won't startup! The battary light indicator isn't showing any light, when I connect to Magsafe to power source it lights in green but still not charging nor starting up. Can someone help me where did it go wrong and how to fix it?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Chosen Solution

The RAM upgrade probably had nothing to do with it. Most likely is that you unplugged the battery for the installation and failed to plug it back in. You might have bent a pin.

Was this answer helpful?

Score 2

Comments:

@mayer How can I ensure that I plug it back in correctly? All pins look perfectly fine to me.

It's very straight forward task!

Also I'm unable to boot the device when connected to external power source. I'm using 60W MagSafe adaptor.

by

Switch the old RAM back. Have you had any prior issues, any video issues at all?

by

@mayer I already tried that still the same. No significant at all.

by

Did you turn the system off fully before taking the RAM out (disconnect the battery)? If the system was still powered when you pulled the RAM you could have damaged the logic board.

Also, did you practice good ESD protection? It's winter with dry air static is a killer as well.

by

@danj Yes it was fully shut down, then I disconnected the battery.

Um I'm not sure what I was supposed to do to ensure ESD protection?

BTW I removed the old RAM and put it back in couple of times, before I inserted the new RAM chips. The only difference is that this time I disconnected the battery. When I was experiencing with the old RAM (removed one and left one, then put them both back) I didn't face any issues and my system recognized these changes.

by

Show 4 more comments

Add a comment

You be sure the firmware update is correctly.

First you need do a PRAM with the machine connected to power.

That is done with the folowing secuence : Command (cmd) + Option (alt) + P + R on a keyboard inmediatly after power on.

Hear 3 beep, following hold off the keys, is the computer didnt startup , may be the damage is more deep and sugest go to a service center.

PD try without battery.

Was this answer helpful?

Score 0

Comments:

@irepair I can't do a PRAM, It won't power on with or without battery.

by

Add a comment

Add your answer

r1m111 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 2

All Time: 137