Why does the installer stop at full bar?


I'm trying to figure out the reason why my Macbook is not fully loading the MacOS Installation ESD. The macbook has no OS, therefore I cannot use any of the special functions such as Command +R or holding shift to enter safe mode.

The installation is being performed through a bootable USB of "El Capitan" made from my other working macbook. I have tried loading "El Capitan", "Mountain Lion", and "Snow Leopard" as a bootable USB. They all fill up the loading bar, but stays there. I have attempted to do this at least 20 times. Two times I have left it overnight, making it over 10+ hours on the full bar without proceeding to the next phase, which is to perform the actual installation of the OS. (The page where you get disk utility and such...)

I have also tried to take off the internal hard drive and disconnect SATA cable from the motherboard, then connected an external hard drive with the OSx El Capitan. When it tries to boot into the OS, the progress bar only loads half way and then slowly fills up the other half in about 30+ minutes. When the bar reaches to full, the OS still doesn't load.

Another things I have tried is reseting the pram and taking off the Ram and relocating it ( the Ram is the original from the mac and have made some test runs with only 1 memory at a time in each ram slot). I have also tried disconnecting the optical drive from the motherboard and running it, but it still does the same. I've also tried reseting the SMC, but no luck.

Additional Information:

The computer was handed down to me, the previous owner was running Windows 7 and told me that he wasn't able to install Mac OS after replacing his hard drive due to it crashing.


Answered! View the answer I have this problem too

Is this a good question?

Score 0


What is your other computer? Do both have Firewire 800 connectors?


Unfortunately no, the other computer is a Macbook Pro 13" Retina Late 2013.


@ Mayer - Sounds like a bad SATA cable to me.


@danj - Are you referring to the internal SATA cable or the external one used to connect the external hard drive? Thanks


The internal SATA cable in your system is likely bad here.

There is no external direct SATA interface. There is USB or Thunderbolt ports in your system which you could plug in either an adapter or an external case to hold your SATA drive. Or, use a USB thumb Flash drive.


Show 7 more comments

Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

1 Answer

Chosen Solution

At this point I would focus on getting the internal drive working here as you appear to be dancing around different external devices which may not have the correct version of OS-X.

The InstallESD.dmg file is a special OS file to allow the optical disk or USB to be bootable with a limited OS-X kernel.

From it you should be running the OS installer app to prep and install the OS onto your drive. One of the problems you can encounter here is not using the correct ESD file for the given OS installer.

Frankly, I don't mess with this method.

What I do is format and prep a USB thumb drive (16GB) as a full OS install. Then I download the OS installer for that version of OS installed on the USB and copy it over to the USB drive so when I boot up the system with it I have everything I need to have to prep the drive I'm either installing as new of repairing the one that is present in the system.

Of course this means you have to be prepared before hand or have access to a working Mac system to create the needed USB drive. Which maybe why you are struggling here as you may not have a compatible OS between the systems you have access to. The other method is leveraging Target Mode but that requires systems which support the same drive interface (FireWire or Thunderbolt) it doesn't help when you have two systems which can't interconnect as you state here.

Lastly, you also had Windows running on this system which could have messed up the boot loader. This is were you will likely need to do a complete wipe on the drive and reformat it with GUID partition table and a journaled file system partition. You'll need to use Disk Utiliy that is on the bootable installer drive to prep your internal drive.

Give that a try to see what happens. If you still have problems then you'll likely need to replace the HD SATA cable as sadly the cable is know to fail often.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Alexis Cervantes will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 14

All Time: 769