Skip to main content

Laptop stuck on boot logo after shutting down

I bought an Asus X553MA Notebook which came with Windows 8.1 about 5 months ago and until then it's worked fine.

I was working on an essay while on Skype and I leant on the power button by accident.

After turning it back on, it shows the "Asus: In Search Of Incredible" logo, flickers on and off twice pretty fast then hangs.

For some reason, the white, spinning circle spins a lot slower afterwards too.

I can get onto Windows Repair and have tried all the options there, but none of them work.

I've seen a lot of the solutions being to taking out the battery in some way, but the case is sealed completely, so I can't get to it.

Answer this question I have this problem too

Is this a good question?

Score -1
Add a comment

1 Answer

Hello Andrew M

In my opinion from the inside of your laptop there must be a button that is stuck but you can also try this see if you can enter the bios by pressing F1 or F2 or Del from your laptop then press F10 to save and exit to see if it will boot normal again this is not 100% positive it will work you can always try

HOPE THIS HELP :D

Was this answer helpful?

Score 0

Comments:

@jeff9x what changes are you trying to save when you exit the bios. What changes are you making to fix the problem ?

by

Add a comment

Add your answer

Andrew M will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 1,601