Revamped version of the iPhone 3G with faster processing speeds. Repair of this device is similar to the 3G, and requires simple screwdrivers and prying tools. Model A1303 / 16 or 32 GB capacity / black or white plastic back.

1952 Questions View all

power/sleep button doesn't work

My iphone 3gs got wet a few months back. I took it apart and dried it out and got everything working except the power button on top and the camera.

So I ordered a new camera module and a volume/headphone/power button flex cable assembly and replaced the parts.

Now the camera works fine, but the power button still doesn't work. All the other parts of the flex assembly work, like the headphone jack, the mute/vibrate button, and the volume control.

The power button is still non functional though. It clicks very well, but nothing happens.

What could be the problem here?

Just in case it helps, I've found that one of the little flex cables that connects the display to the logic board (I think it is labeled '3') doesn't seem to really go in the way it should and appears loose. This is probably unrelated as the teardown for the 3gs seems to indicate that the '3' cable is for the ear speaker, but I thought I'd mention it..

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

no 3 doesn't fit all the way in to the connection, as long as it works don't panic!

by

Add a comment
Black Friday
Broken doesn't stand a chance.

3 Answers

Chosen Solution

try loosening or tightening the screws on the power button flex

Was this answer helpful?

Score 2
Add a comment

I am in the same boat you are. Everything works fine on my 3GS, except the sleep/power button, and it clicks fine, just no response. I really only care about taking screen shots and without the button functioning, it cannot be done.

Was this answer helpful?

Score 0
Add a comment

same boat. new bottom half, with cables and all, so it appears that the sleep/power button failure is on the mobo. I wish I had a diagram of the connection points where the flex ribbon connects, as I think this is where the problem is - on the main board. Anyone?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Cliff will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 3,325