Released March, 2014, features a quad-core 1.2 GHz processor, 1GB of RAM and 4GB of expandable storage.

26 Questions View all

Why is my phone not resetting to its defaults?

Whenever I power on my phone, it shows a white screen on which two options are shown with a warning that internal memory has been damaged/unavailable at the moment:

1. Restart your phone

2. Reset to default

Restart takes it back to same screen and resetting to default does not works.

What to do?

Thanks

Answer this question I have this problem too

Is this a good question?

Score 5
Add a comment

2 Answers

Most Helpful Answer

Hi,

Try to hard reset your phone.

Be aware that a hard reset will erase all your downloaded apps and user data.

If you can, charge the battery before you perform a hard reset. Do not leave the charger connected when you perform a hard reset.

Here is a link that shows you what to do.

http://www.hardreset.info/devices/huawei...

Was this answer helpful?

Score 2

Comments:

Tried this one too. Error while hard resetting too. Failed to do that.

by

Add a comment

Hello,

If U know how to put new softwer on your device do it, search XDA forum for it.

Probably it's SF failure but in rare case can be NAND chip error.

here is some link, probably can help to u! http://consumer.huawei.com/nz/support/pr...

Was this answer helpful?

Score 1

Comments:

I tried but was not able to do anything. No ROM available there yet.

Thanks anyway!

by

Add a comment

Add your answer

Muhammad Asad will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 10

All Time: 1,846