The fourth iteration of the popular 7" Galaxy Tab line of Samsung tablets.

126 Questions View all

Why won't apps download on my device?

Ever since yesterday I haven't been able to download anything from the app store, anything I try to download will freeze at anywhere from 80%-96% and then just stops. I have no idea why. My only guess is there's a problem with the device and I need to reset it to factory defaults.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Most Helpful Answer

Hi,

Here are two options you could look at.

1. Have you tried updating the Google Play Store app?

Open the app, tap Settings, scroll down to Build Version, tap to enter. If there is an update option select it and allow it to update. Try to download an app and see if it works.

If it says it is already up to date, try the following: From Main Menu on tablet go to Settings > Apps > swipe right to All > scroll down to Google Play Store, tap to enter, tap clear data. Try to download an app. Hopefully this may help you.

2. Not quite sure where it is located in your Tab but go to Menu > Settings > Apps > swipe right side to ALL Apps, then scroll down and find Download Manager. The Apps are listed alphabetically, with working apps first then disabled apps.

Block Image

Tap to enter Download Manager. If there is an Enable button tap it then try to go online.

If it says 'disable' tap to disable, then clear cache. reboot Tab then navigate back to download manager and enable it as above.

See if you can access the internet with your browser then try downloading an app from the Play Store.

Hopefully this is of some help

Was this answer helpful?

Score 2

Comments:

Sadly neither options worked. When I went to clear the cache on the download manager it wouldn't clear it. But I did everything else and it still paused at the same percent as it always does.

by

Hi,

One last try. Try going 'offline' with your phone go to Menu > Settings > Wireless and Networks > more > Mobile Networks > Data Connection, tap to enter, select off. This only disables your data connection not your phone. Then try clearing cache / data in download manager. Reboot the phone. Make sure download manager is running, turn data connection back on then try downloading app.

If this doesn't work you were probably right. Back up your phone and then perform a factory reset. Then restore your phone. Hopefully this will resolve your problem

by

Add a comment

Add your answer

TheDiceman91 will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 20

Past 30 Days: 75

All Time: 476