Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

787 Questions View all

Black screen after upgrading to SSD

Hey guys,

after upgrading my MBP 13" 2012 (non-retina), I can't boot the device properly anymore.

First of all, I didn't copy the contents of my HDD to my SSD before because I thought it would be possible to recover my OS via TimeMachine after the upgrade is done (I did make a backup on an external disk indeed)

I used the following adapter kit: http://www.amazon.de/SATA-Adapter-Apple-...

and the tutorial from ifixit.com (the SSD is from SanDisk but the seller said it's 100% compatible with Apple Hardware)

after following all the steps i tried to start my MacBook and indeed i heard the startup sound, but the display screen stays black... I even have issues with the background lightning, as it seemed to work for the first time (I saw some bright lights at the bottom of the display) but now even the lightning is gone.

here are some pics of my MBP, with the main focus on the display cable:

Dropbox Link w/ attached photos

back in the days I had some problems with one of the 4 feet (the upper right one) of the case bc it was loose.. so I fixed the problem with superglue... everything went fine but today, when I opened the case to insert the SSD I realised that the upper corner of the case was somehow "sticky", so the case couldn't be opened easily... i tried to remove the cable carefully... Well i guess, not carefully enough bc now my MacBook shows a black screen :( i think that due to the superglue the display cable was kinda attached to the case (look at the pictures to see what i mean, you can still see some remains on the cable itself) ...

so my question is... is it really the display cable? or could there be anything else? maybe i've forgotten to put something back in its right place?? how can i fix this issue? i tried putting an external display on (via HDMI & thunderbolt adapter), but the second screen doesn't show anything neither.. :/

I hope somebody here can help me bc as a student I REALLY REALLY need my MBP to work again :(

All I wanted was to get my MBP fast again, after Yosemite everything went awfully slowly with my HDD ... but now I can't even do anything anymore :/

thanks in advance guys :)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Ouch! Not good :-(

The glue glued the cover to the cable and when you pulled the cover part off you damaged both the cable and the logic board connector (the cable is part of the display assembly).

Sadly, you will likely need to replace both parts which will be expensive!

Was this answer helpful?

Score 2

Comments:

that doesn't sound good at all :(

so the logic board connector is also definitely damaged?? i mean can u already verify this by the pics i've provided? because even though i removed the cable from the case, i tried to be very carefully (tried to carefully release the cable from the cover it was stuck with) .. i think i could handle the problem with the cable, but a new logic board connector?? i don't even know if it is worth to replace that on a 2012 MBP :(

by

It looks like it's not square to the outline markings on the logic board. While not conclusive given the quality of the image the logic boards shifted connector is not good.

by

Add a comment

Add your answer

wagnerartur will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 5

Past 30 Days: 29

All Time: 514