Repair guides and support for Panasonic's Viera line of televisions.

79 Questions View all

Defective HDMI circuit board?

I have a Panasonic Viera TC-L42U25 and we get a random audio problem with HDMI connected devices. The audio will become distorted with a weird reverb effect.

We started experiencing this when watching our Roku and I switched HDMI ports, but that did not help. I later replaced the HDMI cable and that didn't help. The only thing I've found that fixes it is going to Roku settings and switching the video mode from 720 to 1080 (or vice versa), so I figured the problem is with my Roku. Then on a rare day that we used our DVD player it happened. In this case, I was able to fix it by ejecting the disc and reinserting it. We also have a WII console connected via RCA and there is no such audio problem. It also never happens when watching regular television through coaxial cable.

So, it seems to have something to do with the HDMI signal. Since both ports give the same results, does the circuit board need to be replaced? If so, is it something I can do myself?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

Check to see if your TV has the latest firmware installed. The following link, from Panasonic, has a firmware update, which it seems, addresses your problem.

http://shop.panasonic.com/support-only/T...

Hopefully this is of some help.

Was this answer helpful?

Score 2

Comments:

Thanks for this.

Unfortunately, I'm having no luck creating an SD installer disk in OS X. I've found plenty of instructions online, but can't get it to work.

by

Hi Howard,

Just verifying that you have unzipped the download to extract the SDImage.bin file 5.121Mb in size. It is this file that you need on the SD card. Apologies if you know this. Don't know anything about Mac's, but with PC usually with firmware updates, you just have to copy the file to the 'root' directory of the 'flash drive' or 'sd card'. If you put it in a sub folder then it can't be found by the device. You do not have to create a 'special' installer disk. Once the file is copied to the SD card, when you plug it into the TV it will find the file because it's looking for a file with the correct name. Again sorry if you knew this and have being doing just that. Also maybe you should verify that the TV's card reader is working, maybe by placing photos or something similar on the SD card and seeing if you can view them on the TV.

by

Yeah, I had been trying to figure out how to make a disk from it like I normally would with an ISO or DMG. I finally figured out that I only needed to copy SDImage.bin to the SD card. Everything went well. We'll just have to wait and see if the problem pops up again.

Thanks for your help,

Howard

by

Add a comment

Add your answer

Howard Theriot will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 2

Past 30 Days: 16

All Time: 478