Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

338 Questions View all

USB port not working

I tried all the software options to fix my USB ports and so far no success.

when I purchased my mac last year I could make the usb recognize the pendrive when I tilt it to a certain angle but when I release the pendrive off of my hand the mac stops recognizing it.

First, I thought it was an easy fix, I opened the mac to check for any loose components and while I was investigating the board I saw the device in this link below

http://forums.macrumors.com/threads/i-de...

and from this youtube

https://www.youtube.com/watch?v=YvV0hCN4...

at 2:19

I removed the resistor and put it back the result was not good now my mac wouldn't recognize any device no matter how hard I try tilting and changing the angle of the USB connector.

My question is how can i get the resistor or what are the specs of that component.

My USB do have power so I don't think it's the fuse.

Thanks.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

First off that's not a 13" model give me your serial number of the mac so I can tell you component . Are you using hot air or soldering iron tip.

by

First, thanks for the fast reply.

The serial number is C1MH7JSDDV13

thanks.

by

Bro, that picture is not a 13" model there is no fan connector opposite side of the usb's , is this the picture of yours or another, that is a 15" model I recognize that large bga

by

The part that fell off i'm preety sure is a choke coil. I am not sure of the measurement I still think that's a 15" board.

by

sorry for the confusion the links above are not of my macbook.

I took a picture of my mac and here is the link

https://drive.google.com/file/d/0B0tKh5r...

my mac is 13" and it's late 2011

i damaged the right component inside the red square. I believe the left component is the same.

by

Show 1 more comment

Add a comment

1 Answer

Chosen Solution

Choke coil -Inductor part number DLP11S- rated at 90-OHM-100MA make sure you make sure it's 100MA you can get this from digi key singled.

Either order from digi key or get a parts board from ebay. You are going to need to solder the through-the-hole usb ports to tighten up your first problem, hope you still have pads where you pulled off the inductors.

Was this answer helpful?

Score 1

Comments:

when i go to digi key and select 100MA I only get 240-OHM (DLP11SN241HL2L)

and when I select 90-OHM I get 150AMA (DLP11SN900HL2L) . is it possible to use one of these two or do I have to look somewhere else?

by

Try the 100MA 240-OHM it should work

by

thanks, I will try 100MA-240-OHM and I will post the result.

by

got the parts and installed them. the left usb is not working but the right one is functional. I guess the left usb eight lost the pad or something else but now at least i have one functional usb. your help was much appreciated. Thanks.

by

Awesome glad to help , if you'll look closely you may be able to see where the pad is missing ,the trace to the next component you can use a fine wire to build a jump to the missing pad on one of the components leg from the pad that's missing you will have to have the boardview and schematic which you should be able to find on google , you will be looking for 820-2936-A

by

Show 1 more comment

Add a comment

Add your answer

Hamid will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 26

Past 30 Days: 123

All Time: 879