The Samsung Galaxy S3 is a multi-touch, slate-format smartphone with eye-tracking ability, increased storage, and a wireless charging option.

594 Questions View all

(Can't connect to camera) S3 i9301 with CM12

Some days ago I installed a Resurrection Remix Rom (I actually don't know which one, sorry. I just know that it's got Lollipop) and when i went to the camera it said: <<Can't connect to camera>>

I still had warranty, so I installed the stock rom (I checked the camera and it still didn't work) and I sent the phone to the company. IMPORTANT NOTE: In the warranty ticket it said <<SOFTWARE ERROR>>

The only camera I can use is the "selfies" one

When I received it, the error was fixed, so I tried to install another ROM, so I installed CM12. But... I got the error AGAIN and I haven't got warranty anymore

That's what I tried

-Install Reset Camera and Camera (CMFix) (Camera CMFix didn't open and I had Restart Camera Installed :v)

-Checking if an app is having troubles with the camera

-Rebooting in safe mode

-Holding down the volume/power/back

-Clearing Data and Cache of the camera

-Removing my SD card

-Renaming the DCIM folder

- youtube. com/ watch?v=Fa9qggQJ990 (I can't even access to that menu ._.)

-Find “Use NuPlayer” and uncheck it & restart

-Using other camera apps

-Disabling the Google Camera and using the default one

-EDIT: I installed the Stock Rom with odin and did a factory reset. I even did a "system reset" with odin. AND IT STILL DIDN'T WORK OMFG. Then I tried to update the camera firmware (youtube. com/ watch?v=Fa9qggQJ990) because I've got KK now, but the "Phone/CAM FW Ver Check" is disabled. I googled my camera Cam FW Ver and it's not old

Thank you, I'ts a really annoying error. My S3 is giving me too many troubles, I'm starting to hate it... But I can't buy a new one


Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment
Free shipping on orders over $20
Use code BLUEANDBLACK at checkout
Free shipping on orders over $20

1 Answer

I had experienced the same problem,

I could solve it thanks to the fix given here for i9301q

Was this answer helpful?

Score 0


Also CM is discontinued. Use LineageOS.


Add a comment

Add your answer

Mario Ortiz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 9

All Time: 814