Sennheiser RS120 Wireless Headphones with recharging cradle

39 Questions View all

Frequently I get a very very loud static sound in my earphones

I have two headsets for the RS 120. One is fine. The other one sends a horrible loud burst of static every now and then and scares the !&&* out of me. Can anyone relate?

Can anyone advise how I could prevent this?

Thank you.

Answer this question I have this problem too

Is this a good question?

Score 3
Add a comment
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12
Spread Fixmas Cheer
Get $12 off your purchase of $50 or more with code FIXMAS12

3 Answers

OMG the same thing keeps happening to me

Was this answer helpful?

Score 0
Add a comment

Same problem here with two sets. Any answers?

Was this answer helpful?

Score 0
Add a comment

I don't get a loud burst of static. My bursts are repetitive but low in volume.

I've found the following helps:

-- Moving the base station (where we hang our headset overnight) to where there's minimum obstruction between it and the headphones.

-- Turning off Surround Sound. That's done at the lower right of the base station. When SS is on, the base station has a yellow light. When the light is off, that helps. (Me, anyway.)

-- Try a different channel. That's done at the lower left of the base station. Might have to turn off the headphones to let it find the new channel. Or, on the left headphone, push the channel button. (Not 100% sure if this left headphone button tip actually works.)

Hope this helps someone. I love my Sennheisers.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Lynne Fletcher will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 4

Past 30 Days: 29

All Time: 957