Is the logic board dead? (MacBook Unibody 2009)

Hi guys,

So I've recently acquired a white Unibody MacBook as a fixer-upper. I just need confirmation of the symptoms that the logic board is dead, because it simply doesn't turn on.

Here's what I know from the previous owner:

  • It did not come with a MagSafe adapter (had to use my own 60W)
  • It has apparently "not been used in two years"
  • Pretty crusty and dirty, lots of grime and dirt on the edges, corners, and keyboard (gave everything a careful swabbing with Q-tips and 90% rubbing alcohol).

Here's what I've done:

  1. Plugged in MagSafe -- light was orange for maybe 5 seconds, then switched to solid green.
  2. Does not respond to the power button being pushed despite being plugged in.
  3. Opened it up, put in some new RAM (that I know is working). Repeated steps 1 and 2. No power.
  4. Left as-is, attempted to manually turn it on by shorting the "power pads". No power.
  5. Unplugged MagSafe, unplugged battery from logic board. Plugged MagSafe back in, stayed solid green. Pressed power button, no power.
  6. Repeated step 4 with battery unplugged, no power.

And that's the extent of my testing! Do these symptoms say the logic board is pooched? Or is there some other component I'm missing that prevents the MacBook from turning on?

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

It's sleeping not dead, on one of the sides of the power pads are you getting 3.4v with a multimeter?

by

You need to pull out the keyboard ribbon too I've seen many times it can stop from booting cause it's bad otherwise jumping from the pads if that's the case, won't do a thing.

by

Add a comment

1 Answer

One of the possibilities is that your power keyboard/power-button isn't functioning. One way to see if this is the problem is to disconnect the keyboard and then connect the Mag Safe adapter. When the Logic Board senses power, and the keyboard isn't connected the machine bypasses the interface and boots. This isn't definitely your problem but it will help narrow things down. Let us know if it works :)

Was this answer helpful?

Score 0

Comments:

Thank you Shmajay and John for your input about the keyboard. I have tried all the steps again (in my original post) but with the keyboard completely disconnected from the ZIF connector, but the system is still the same! No power whatsoever. Tried both the power button and the power pads on the board.

And John, I don't have a multimeter handy, currently scouring the house for one... will update once I get a reading.

by

Did you have any luck with this? I am also having the same issue. Tried all the steps above.

by

Add a comment

Add your answer

Internets will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 245