Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

239 Questions View all

iMac display not working

I have an iMac 2010, 21,5" which has hardrive problem and replaced it. While connecting its LCD with display connector cable, the cable got damaged at one end. I got new display-port connector cable, but still display is not working.

When I connected with external monitor, its working fine.

I asked at a local repair store they told me that it was either the LCD panel, or the SATA/Board (Logic board?) which would even be more expensive.

I thought its a LCD problem, got LCD from ebay but still the display is not working.

I did a SMC/PVRAM Reset, but this did not solve the problem.

I used flashlight and cant see anything on the internal screen.

My question is whether it's possible to determine if it is the logic board, cable connection, the Backlight controller or the LCD-Panel.

Thanks for your answers,

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Fans running at full speed too?

by

Add a comment

2 Answers

Most Helpful Answer

You should try the diag leds first to see if its the lcd. They are just above the mic connector on the logic board. The #4 led is green if the lcd is making connection with the motherboard. If the #4 led is green, maybe the motherboard defective because you changed the lcd and the lcd cable allready.

Was this answer helpful?

Score 1

Comments:

I did check the LED, #1 LED green, #2 LED green, #3 LED green but #4 LED is off.

by

If you allready changed the lcd and the lcd cable i am thinking about the motherboard connector. Try to change the lcd temp cable the thin one.

by

Add a comment

I had the same problem. Only external video, LED4 of. In my case, inductor L9000 of the logic board was gone. If you want, have a look at my post

After HD changed, fuse (wall) tripped, no internal video, but external

Regards.

Was this answer helpful?

Score 0

Comments:

SAme problem here.. already bought the fuse.. but can't locate the L9000 circuit on my MB..please Help!

by

Hi Christiano,

I just updated my answer to my own post. Hope, this helps.

Regards from Hamburg

After HD changed, fuse (wall) tripped, no internal video, but external

by

Add a comment

Add your answer

Shailender Rachamalla will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 12

All Time: 307