MacBook Air models with 13" displays

1475 Questions View all

Voltage Problem on 2011 (EM2469) MBA

Hi!

I am currently trying to figure out why my MBA Logic Board is not working and the Battery is not charging. I tried to follow the Schematics from the power in to where the voltage drops.

Until this chip I keep my around 14V but on one pin it drops here (red squared one)

Block Image

http://share-your-photo.com/bb19b27a69

The Connector which goes to R6920 only has 1,27V on the Multimeter, but the other two connectors of D6905 have the +/- 14V. Is that normal? What kind of part is D6905?

This is the chip on the board (red square)

Block Image

http://share-your-photo.com/47fe572d46

the red circle indicates the component on the board which gets very hot, after plugging in the charger it takes around 30 seconds and I cannot even touch it anymore without burning my fingers.

All measuring was without battery. Charger only has the green LED on, nevermind whether the battery is plugged in or not and the board does not start.

Thank you very much for your help!

chris

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Most Helpful Answer

Chebno, this is just to answer your question about D6905. It is a BAT30CWFIL Schottky Diode. Available at places like this You seem to have the right schematic so not sure where your problems are in identifying those components. Check the voltages on lead 2 and 3, it should be ~18.5V per your schematic. the part that you outlined as heating up is C7284 all part of your 3.3V power supply.

Block Image

Was this answer helpful?

Score 2
Add a comment

Add your answer

Chebno will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 39