Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus.

3286 Questions View all

Reading Sim Card, Not Getting Network Connection(Searching/No Service)

I've recently purchase what I thought to be a barred iPhone 6. However upon doing a Check Mend request I found that the device is in all working condition. Which isn't barred or blacklisted via the networks.

So I've tried to install a few different sim cards. The only sim carrier that doesn't ask for Activation is O2UK. So I figure it's on the O2 Network. However when I insert any O2 sim I only get a 'Searching' or 'No Service' message at the top of the screen.

I have replaced the charging block, as I believe that is where the coax cable is for the antenna. However 3 charging blocks later and the same issues are still occurring.

I've have followed the Apple guide on troubleshooting this issues. From re-installing my sim card to resetting networking settings. None of these methods have had any success.

Any ideas?

EDIT: Here is everything I've now tried - basic troubleshooting like airplane mode and hard reset has already been done.

  • Replaced Charging Block
  • Replaced Wifi & Bluetooth Antenna
  • Replaced Main Board Flex (Coax Cable running down the back of the motherboard)
  • Got the device unlocked, hoping it was a simple network issue
  • Made sure the device isn't barred (It isn't)
  • Place the board into the shell of another iPhone 6. Same issue is occurring so I'm highly confident that it's a issue on the board itself. Although I have looked around and can't see anything out of place.

Another thing I'd like to add is that every now and then the date and time setting 'Set Automatically' doesn't always grab the right time. Yes, I'm connect to Wifi and I know it's working cause I can download applications from the App Store. However from time to time it'll be set 2 minutes behind. As I know signal can't be affected by the Date and Time.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

Try turning the phone off and then back on. Try turning airplane mode off and then back on. Try updating carrier settings

Was this answer helpful?

Score 1

Comments:

I've tried all of these. Unfortunately nothing worked. I believe it to be something on the board as I've done a board swap into another working iPhone 6 and I get the same problem.

by

The next thing I was going to say is disconnect the battery, then re-connect the battery. Then connect to wifi, to get the proper date and time. I've had that work for me, in the past

by

I have tried this. I've even replaced the battery as the battery did seem to drain a lot quicker than it should. However about the date and time, it seems the 'Set Automatically' option doesn't get the correct time. Maybe 1 or 2 minutes out.

by

Add a comment

Add your answer

Edward Gough will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 12

Past 30 Days: 49

All Time: 695