No sound from notifications

Hi, i got a Nokia Lumia 635, and i just changed the screen today (was broken). I did fine, screen is working perfectly, i took the speaker of the old screen and put it into the new one like i read, but here's the problem : i don't have any sound coming from my phone system.

Let me explain a little more : calls are ok, i can hear perfectly and i'm heard. But there is no ring sound, no notification sound. BUT it works if i plug a heaphone in.

I don't know if the problem comes from the new screen i put on, or not. After resetting my phone to see if it was a software problem, it still doesn't work like usual. So i guess it's on the new screen block that the problem is. Anyone sparing an advice ?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

Hi,

As I understand you have a problem with the ringer (buzzer).

Open this manual:

Nokia Lumia 635 Display Assembly Replacement

than go on step 3, the second picture.

The buzzer is on the rear bezel (down left). There are not a direct contact between the buzzer and the main board.

Now see at the display assembly (same picture - down right). There is one yellow flex cable stucked on the display assembly. This cable makes connection between MB and buzzer. Check this cable, also check the small gold pins on the main board, near to the buzzer.

Was this answer helpful?

Score 2

Comments:

Well, I looked at the cable that links the earspeaker to the MB and also the gold pins. All of them make contact. Also, not damaged nor oxidized.

only thing I could notice was the yellow stick (near tooth pick, step 3 second picture) was a little bit peeled off. Any chance this is the source of my problem ?

by

Check if isn't shifted and check the golden lines on it for a damage (use a magnifying glass). Check also the pins on the ringer.

The first thing that I will make in this situation, I will check the ringer and the lines on the yellow flex cable with a multi-meter. Then I will know where is the problem.

by

So i tried to look really closely at my phone. Managed to take some pictures

https://photos.google.com/share/AF1QipMO...

I don't think there is any damages on the golden lines, the pins are fine too.

Only thing i could fine was that the flex cable was a little bit folded (5th picture, below the gold chip)

Thank you for taking on your time to help me though

by

Yes, everything looks OK. I strongly recommend you find a multimeter and check the buzzer pic.2 and the ribbon cable lines pic.3.

by

OK ! So i got myself a multi-meter. Just had how to learn to test continuity (pretty simple, it's all logical stuff), then went to test my phone. I found a continuity break between 2 gold patchs (on the third picture, between the two at the bottom of the picture, you can see a little break on the gold line when it comes over the border between silver and black part). I scavenged the old one on my old screen and switched it on the new one, and it's working again perfectly fine now.

A huuuge thank you, you're the MVP here :)

by

Show 1 more comment

Add a comment

Add your answer

gbpc will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 12

Past 30 Days: 29

All Time: 1,394