The Apple iPhone 5c was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 8, 16, 32 GB / White, Pink, Yellow, Blue, and Green.

1386 Questions View all

Home button will not work after replacement

Hello,

I have this stubborn iPhone 5c which I can not get the home button to function. I have replaced both the button and the charging port twice to no avail. Even ios restore. Does anyone have knowledge of this issue?

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

did the home button just stopped working by itself? or did this occur after a repair?

by

I was given this phone by a customer. He claims it was never fixed before, I don't see any signs of previous tampering it is just "the home button would only sometimes work."

Well in my experience with it thus far it has never worked.

by

Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

check the contacts on the charge port and make sure they are not bent or damaged, also make sure the contacts on your button piece are aligned correctly as well. One issue during a charge port installation can be the port not being aligned properly as well. If all pieces are in correctly and the issue persists it could be a board or software issue. I would try a settings reset as well if all pieces are in there correctly.

Was this answer helpful?

Score 0

Comments:

Hello,

Thanks for the reply, but I wonder if you read the post and not just the title. I have replaced a thousand charging ports, and this one in particular I have done twice, as well as the home button. I even did the full restore already. I am often able to test a home button on a charging port by simply holding the contacts together, as the screws do absolutely nothing for its function. On this one, however; I can not get function even with the home button and charging port fully installed.

by

Add a comment

The cable with the home button contacts must be aligned exactly right. The cable has two alignment holes that fit over corresponding little nibs when the cable is bent over itself i the proper way. There is also a bit of adhesive on the back of this cable to keep it in place. Then the whole assembly is screwed down. If the contacts are not bent then my guess is that the cable with the contacts is not indexed properly. Regards,

Ed

Was this answer helpful?

Score 0
Add a comment

Add your answer

ifix will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 48