Repair guides and support for your Samsung TV.

769 Questions View all

My Tv won't turn off or change inputs...

My Samsung ln46a650 won't turn off or inputs from remote or from tv itself. The light on the tv shows me its reading the remote so why wont it shut off the tv or even on the tv itself...

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

Rob, possible bad relay, bad caps etc. What have you checked? Have you opened the back and take a look at the power board?

by

I have opened the back... but i can't say i know what I'm looking at oldturkey03

by

What happens when you pull the power altogether (unplug)?

by

It powers up after plugging it back to power source. It reads the remote and responds to (on tv buttons). BUT after awhile the problem comes back. I cannot figure out what the source of the problem is.

by

I agree with oldturkey (and I am never going to catch up to him!): post pictures. That said, works and then eventually fails smells like a failed capacitor, or bad / cracked solder joint or trace. Rationale: the components that are time or heat sensitivity tend to be those.

In the meantime, you have also effectively found a work-around: put a switch (like a power bar) and turn it on before you want to use it. Not a bad idea from a power-savings and safety perspective, although less convenient.

by

Add a comment
Deck the Halls
With tools and Fix Kits

3 Answers

Chosen Solution

Rob, check the power board. It should look similar than the one in the image. Check for anything odd looking. Post some images of your board with your question. Use this guide to help you with that. Just make sure that yuor set is disconnected and that you don't poke around the components with your fingers, Capacitors will hold a charge, even when the set is unplugged, and may giving you a shocking experience.

Block Image

Was this answer helpful?

Score 2

Comments:

Trashhhhhhhhhhhh

by

This website really badd

by

I just got scammed

by

@cathi how did you get scammed? Which website is really badd and what is Trashhhhhhhhhhh?

by

Add a comment

I got this problem when i messed up the configuration on secret menu. Cant realize what did i change to change back :(

Was this answer helpful?

Score 0
Add a comment

Assumming its not a universal remote that has forgot the code or week Battary check the standby voltage on main logic and look at the plugs on that board there marked what voltage they should have if there all correct then its your main logic ( I'm betting that's what it is )

Was this answer helpful?

Score 0
Add a comment

Add your answer

Rob will be eternally grateful.
View Statistics:

Past 24 Hours: 27

Past 7 Days: 157

Past 30 Days: 837

All Time: 12,879