Repair guides for Android cell phones manufactured by ALCATEL One Touch.

833 Questions View all

Why is my phone not coming on after reset to factory level?

i reset my phone to factory mode and then restarted it but it refused to turn on, what should I do. It is only showing Alcatel onetouch pop d3 and that is all no further booting, it ends there. What should I do or can you recommend any nearest phone repair boot in kamloops for me that repair Alcatel phones.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution


Did you try a hard reset as shown below.

If not try the following, if so try it again.

Ensure your phone is charged before trying this

Make sure the phone is OFF then:

Press power and volume up buttons at the same time

When Recovery screen comes on release both buttons

Press the volume down button to choose Recovery Mode

Press power key to confirm

Press volume up/ down button to choose “wipe data/factory reset”

Press power button to confirm

Press volume up/ down button to choose “Yes--delete all user data”

Press power button to confirm

Choose “reboot system now”

Press “Power” button to confirm

Warning: this action will erase all your personal information and downloaded apps.

Was this answer helpful?

Score 2


i tried hard reset but its still not powering on after choosing "reboot system now". What should I do next?



The only thing I can suggest is that you try a hard reset again with the charger connected and switched on.

If that doesn't work, get a quote from a cell repair centre near you.


Add a comment

Add your answer

inwon david will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 251