Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus.

3141 Questions View all

Touch screen works briefly then freezes

Hi,

I have an iPhone 6 and the touchscreen will freeze randomly. Sometimes I have to wait five minutes from start up for it to respond. Sometimes it works straight away but only for a few minutes. Sometimes it'll work for twenty minutes. There is no rhyme or reason to it freezing.

Here's what I've tried,

1. Soft resets - didn't help.

2. Factory reset and set up as new device- didn't help

3. Fitting x 3 new known working screens - didn't help

4. Cleaning the connectors with iso alcohol - didnt help

5. Updating software which went fine (no error codes) - didn't help.

Probably helps to mention I've switched the motherboard out of a damaged housing to another genuine housing. I own a small repair business and can strip most parts almost blindfolded.

I can't see any physical damage to the board and if the mobo touch connector were damaged the rogue white lines would appear.

Any advice would be appreciated.

Thanks in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 2
Add a comment

3 Answers

Chosen Solution

Solved.......School boy error, wrong screws in wrong holes for connector shield causing visible trace damage to centre and bottom right screw holes, that'll teach me for working late and removing both motherboards at the same time. Anyone know a mobo repair specialist in the UK?

Update.....After consulting the legend that is Jessa @iPad rehab it seems it's a touch ic failure which is common with the iPhone 6. The trace part of the mobo is under a metal shield so unlikely that's the cause.

Was this answer helpful?

Score 0

Comments:

Sorry if it's obvious but with "touch ic" do you mean touch ID? I have this problem aswell with an ip6 and it doesn't freeze as long as the screen isn't fitted in place (sitting loosely on top without connector shield)

by

Nope, touch ic is a chip on the motherboard.

by

Add a comment
Most Helpful Answer

If it weren't for the setting up as a new device, I'd say it has too much memory stored

Was this answer helpful?

Score 1

Comments:

I'm going to return the motherboard to original housing tomorrow, although I can't see it will help. Original housing is 16GB (same as mobo) and the other is 128GB but I'm pretty sure they are identical.

Thanks for your comment.

by

Add a comment

Had the same problem and solved this by unscrewing the middle screw of the connector shield. Any ideas as to why this works?

Was this answer helpful?

Score 0

Comments:

That didn't work for me. I completely removed the shield and still no joy. Your problem could be caused by mixing up the screws for the connector shield or possibly slightly out of place/loose push connectors. Could possibly also be a sign the ic chip is on its way out.

by

Add a comment

Add your answer

James will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 16

Past 30 Days: 85

All Time: 1,099