Complete disassembly and installation guides for most recent Mac laptops and consumer desktops.

31779 Questions View all

spinning wheel ON SAFARI

while on safari i keep getting the rainbow spinning wheel do you think i have to replace the hard drive? i have a macbook (13" alum late 2008) / with my apple care expired

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

I would start be emptying Safari's cache and reset it. Reboot your machine and see if that helps. If it doesn't it can probably be a corrupt p-list file or a permissions problem, and the easiest way to resolve that is to completely delete Safari and reboot and reinstall/ repair permissions. Do you get the spinning beach ball on all applications, or just Safari?

Was this answer helpful?

Score 4

Comments:

Yosemite won't delete Safari.

by

Add a comment

Use Firefox. I have the same problem, Safari just gives the beachball of death. I've tried everything, including a reinstall of Snow Leopard and a reinstall of Safari (and cache clearing and pram clearing and repairing permissions, etc etc etc.) Everything else works fine.

Took to an Apple Store. Eventually they diagnosed a failing hard drive. I replaced it and all is well.

Was this answer helpful?

Score 1
Add a comment

A lot of the solutions are from long ago. Here’s an update with a more recent Mac system. Problem: The spinning wheel would show up about every 15-30 secs and Safari would stall for about 5 sec. I cruised lots of forums and there were lots of suggestions. The three steps that solved it for me were:

1. Clear Safari history.

2. Trash the preferences file "com.apple.Safari.plist", located at: HD > (your user account) > Library > Preferences. Restart Safari.

3. Run Disk Utility, “Repair Permissions”.

iMac 27", OS 10.9, Safari 9, 1. 1 TB.

Was this answer helpful?

Score 0

Comments:

not able to delete the "com.apple.Safari.plist" I get: "com.apple.Safari.plist" can't be modified or deleted because it's required by macOS.

by

Facing the same issue. Have you been able to resolve?

by

I took it to apple genius bar and they reset the Pram

(Shut down your machine. Yes, all the way down, not sleep or logging out.

Press the power button and then press command-option-p-r. ...

Hold those keys down until your Mac reboots again and you here the startup chime.

Let go of the keys and let your Mac reboot normally.)

They also unchecked all the login items:

Go to System Preferences - Users & Groups - Login Items remove all your login Items if any

That solved for an entire day but the next day the problem came back.

Did the P-ram reset again this morning and so far seems to be working.

by

Add a comment

Add your answer

RICARDO CORONA will be eternally grateful.
View Statistics:

Past 24 Hours: 14

Past 7 Days: 76

Past 30 Days: 364

All Time: 15,773