Repair and disassembly guides for Asus tablets.

351 Questions View all

User interface won't display

Original Post: Asus MeMO Pad 8

The Asus MeMO Pad 8 (ME181C) tablet user interface has disappeared. The screen lights up but there is no display. It will not restart at all either. None of the soft or hard reset options have worked. I've also tried letting the battery drain completely so it would (hopefully) turn itself off to reboot. No joy there either.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

You can try and reflash your tablet sounds like something got corrupted

Below is a link that hopefully will give some info that may help you recover your tablet

http://forum.xda-developers.com/general/...

The following two links are from Asus regarding how to update firmware and also the firmware itself (I think)

http://www.asus.com/support/FAQ/1011948/

http://www.asus.com/us/Tablets/ASUS_MeMO...

If not happy to try above, check your warranty, if still valid contact the manufacturer.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Lydia Brown will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 95