An Android 4.4.2 smartphone released November 1, 2014.

47 Questions View all

I can't turn on my Tablet

I was playing a game called Summoners War and I left my tablet for a couple minutes. When I came back, it was off. I just assumed it had gone to sleep mode after being inactive for 3 mins. When I tried to power it on, it just flashes and doesn't turn on. I hold the power button, and it just flashes a couple times then turns off. I just press and release, and no response. I didn't drop it or anything and I have no clue as to why this could be happening. It's a blu touchbook 7.0 Phone/Tablet.

Answer this question I have this problem too

Is this a good question?

Score 2

Comments:

Hi,

Have you tried connecting the charger? Does the tablet respond that it is charging?

by

Add a comment

1 Answer

I live in the Bahamas an i have a touchbook and its doing the same thing.

whenever i plug in the charger its flashes the battery and I have tried the reset and it goes back to the same things .the flashing battery .

Please advise where can i get help or where can I send to repair.

Was this answer helpful?

Score 0
Add a comment

Add your answer

alexanderpk4 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 116