Screen Flickering until I put it on it's back.

Hello there,

Thank you so much in advance anyone who can help with my question.

I've just received a LED Cinema Display 24 inch which I have plugged into my 2011 Macbook Pro 15 inch with Yosemite and the latest OS installed.

When I turn the Macbook on with all wires plugged in the laptop the screen flickers uncontrollably which also causes lag to mouse movement as if the display is constantly connecting and disconnecting.

I've scoured the internet and found that there was a common problem which occurred to all LED Cinema Displays when Thunderbolt was introduced which caused them all to bug out with the same problem that i've described.

I've looked around for the fix which apple no longer supply and have found what I believe was the fix but it didn't work.

Currently the only way I get it to work is to put the whole monitor on its back and after a few minutes it powers into life and works perfectly fine for hours and hours until the computer is restarted then the problem occurs again.

Does anyone out there have a solution or a suggestion? is it a problem with the wires or a software problem? I've tried jiggling the wires to no avail and before I open it up to have a more in-depth look at the soldering on the board where the wires are connected I thought I'd ask the wonderful community to see if anyone else had the same or similar problem and whether they fixed it or someone who might have an educated guess as to why this is occurring.

Sorry for the long essay and again for anyone prepared to help thank you so much in advance.

Peter

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

I have the exact, and I mean exact, same problem. Sorry I don't have an answer for you - but I thought I'd let you know that you aren't the only one. If you find out what the problem is I'd love to know. I'm about to write off the monitor.

by

Add a comment