Laptops manufactured by Asus.

1024 Questions View all

ASUS UX303 laptop not waking up

After an Ubuntu update (I do not know if this is related) it seems like my laptop got completely stuck.

Basically, I can see the led turned on, above the power button (just another button on the upper right part of the keyboard), on the CAPS button, on the side, when the charger is in place the led is correctly showing the battery charging (orange) or fully charged (green).

Still screen stays completely black, HD led gives no sign of life. It is LIKE if it went into hibernation (or sleep) and cannot wake up. Very frustrating.

All I could do was keeping the power button pressed for the longest time. LEDs turn off and then on again, but nothing changes overall.

I lifted up the bottom, tried excluding the battery but of course the problem is not there and I have no clue on where to look. Any hints?

Answer this question I have this problem too

Is this a good question?

Score 2
Add a comment

1 Answer

HI, could I know if you have solved this. Seems like I am having the exact same problem.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Eu GND will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 5

All Time: 470