Black Screen, No Boot, LCD is on but nobody's home.

Hi.

I've recently replaced the screen on my Z3 Compact (I've done this a few times before...) but I think this time I've definitely done something wrong.

Symptoms are as follows:

Phone is on, LCD is working (I can only tell this from the backlight being on) but nothing will boot up. I turn the phone on and I don't get a splash screen or boot up noise.

I've tried resetting it using the power button/volume switch but still get nothing

Any Ideas?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

4 Answers

Most Helpful Answer

I had this issue on Sony Xperia Z Ultra once and it was because a component was knocked off. Sometimes when you pry to get the connector off you can also knock off a component. On the picture I have circled the components that if damaged or knocked off would give "No Image" and symptoms similar to what you describe. I would check all the other components around the connector as well and see if you can see any damage.

Block Image

It could also be a faulty screen. If you try another screen that you know is working obviously that would eliminate it as the problem.

Was this answer helpful?

Score 2

Comments:

Thanks - I'll take a look when I get home.

by

Does this image apply to xperia Z3?

by

What are these components and what do I do when there is one missing? How can I get a new one?

by

He miss one component like that on my Z3 and i got no image but a white or black screen. What can i do?

by

Add a comment

Hi, I have the same problem with a Z1 compact. The broken screen DOES light up, the new screen shows ONLY backlight.

When I try the new screen on a DIFFERENT Z1 compact, it DOES work.

So it looks like this particular Z1 does not want to work with this new screen.

But what can be the reason? The broken screen works (at least, lights up and shows image), the new one does not. (on this device)

Was this answer helpful?

Score 0

Comments:

You may need to try a new screen, I have had issues with different displays. Some displays have different versions.

by

I have the same problem with z3. I have removed the screen and attached it again with adhesives as it was coming off. The phone seems to be functional but only the screen does not work. (black background only)

by

Add a comment

i have a Z1 with the same problem, cant seem to find a solution

Was this answer helpful?

Score 0
Add a comment

Same here, but what are these component, resistance that we maybe can jump or another like capacitor ?

Was this answer helpful?

Score 0
Add a comment

Add your answer

matt wilson will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 28

Past 30 Days: 113

All Time: 2,883