Released June 2012 / Core i7 processor with Turbo Boost / Up to 1 GB DDR5 Video RAM

274 Questions View all

The SSD in the Dual Drive isn't recognized

So I followed the complete guide (and followed it in reverse) to insert the Dual Drive into my Macbook Pro. But when I power my Mac, it won't recognize the SSD that is inside the Dual Drive enclosure. It doesn't show up on Disk Utility and doesn't show up in Startup Manager either (pressing ⌥ at startup).

I haven't tried to connect the drive directly to my Mac through USB yet.

The SSD in question is the Crucial BX100 250GB.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

First make sure your systems firmware is upto date. Follow this Apple T/N: About EFI and SMC firmware updates for Intel-based Mac computers.

If your firmware is upto date your system may not support your SSD in the optical drive carrier. Most SSD's today have an auto setting SATA port. But, some MacBook Pro's have problems with these drives as the optical drives SATA port is somewhere inbetween SATA II & SATA III. Sadly trying to find a fixed SATA II (3.0 GB/s) SSD is getting difficult.

Was this answer helpful?

Score 4

Comments:

Thanks for the answer. I just checked and the EFI and SMC versions are all up to date, so I'm guessing my Macbook Pro has those problems.

This kind of sucks because I wanted to use this second SSD to use for Windows, because for school I have to use software that's only available for Windows. And I would rather install a second SSD than buy a whole new Windows laptop.

by

Even if you got the SSD working BootCamp can't really handle dual drive setups. You could create a Fusion Drive with your current internal HD with the SSD (if you got a SATA II version) and then install Windows via BC which is how we do it when we have a dual drive setup.

by

You may want to look at the Western Digital Black2 dual drive. It would replace your current HD but as it's a true dual drive (HD & SSD) you can see them each discreetly. The other option which is what we use is a Seagate SSHD hybrid drive. Here you have a deep SSD cache and a HD. The drives firmware manages the placement of the files as needed unlike the Fusion Drive where the OS does this.

by

Hi, kind of late reply. I think I found the solution to this problem, although it's a bit late now because I already took the SSD and Dual Drive out of my Mac and put the optical drive back in.

Anyway, I think I had to format the drive. I never did that. But I just bought an enclosure for the SSD, so I still have some use for it, and it gave the same error after plugging the drive with the enclosure in. I checked Disk Utility and it appeared. Then I formatted the drive and now it's usable.

I feel really dumb for never thinking of trying that.

by

yes, you do need to prep the drive. But in your question you stated the drive did not show up with disk utility. If it had I would have pointed you to creating the GUID partition map & formatting it. Sadly, this model has a history of not supporting SATA III drives in a dual drive carrier so I still think you would have had a problem.

by

Add a comment

Add your answer

Alex will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 12

All Time: 650