My ASUS F550W seperate touchpad buttons don't work

Hi, my seperate left and right touchpad buttons don't work, I have tried switching left and right functions and that simply makes clicking in the main touchpad act like a right click, so there must be some error with the actual buttons. I have an ASUS F550W and I am running windows 10, I thought the error had something to do with the new OS but I have checked everything to do with that so I don't believe that is the case

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Chosen Solution

I had the very same problem. After finally finding the control panel. I deleted the elan pointer under the mouse settings in device manager. I then opened C:\program files\elantech\ETDUn_inst

I then restarted the laptop

this solved my issue, until windows auto installed the driver again.

Sp we just need to stop the auto install to fix it permanently

Was this answer helpful?

Score 1

Comments:

right i fixed it now

do the above, the upon restart install this driver

TouchPad_ELANTECH_15.6.0.3_W10x64_A

its actually an acer driver. but it fixes the fault

by

Thank you this worked perfectly for me, A few other people I know have also had this issue and I will pass it on to them as well

by

Add a comment

Add your answer

Senrab will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 4

All Time: 389