Magsafe LED going ON/OFF and the battery icon changer on/off

Hello friends I again,

I got a MacBook Pro 13 " early 2011 with the following problem. The magsafe is plugging and unplugging (led go ON/OFF), and the battery icon changes accordingly, and as if it were placed and taken out of its connector.

I tested three different magsafe and all the problem repeats itself, most work well in other Mac.

My doubt is, would issue the logic board Magsafe (internal) or own mac motherboard?

Is there a way to isolate the problem, because despite other available Mac'm afraid to dismantle the good and then appear any problems in assembling already reset the PRAM and SMC the problem continues, the difference is that there are times that seems to begin to measure the Mac heats.

All help is welcome, and apologize for my poor English.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Your MagSafe DC-In board contacts are damaged. The fact your screen Icon alters from the battery to AC cord implies that. The middle pin is the signal link between charger & your system. Also make sure the AC power adapter cord is not damaged if it is get a new power adapter as you could short out the signal pin damaging the logic board.

Here's the IFIXIT guide to replace it: MacBook Pro 13" Unibody Early 2011 MagSafe DC-In Board Replacement.

To see the systems thermal sensors download this app: Temperature Gauge Pro. Paste a screenshot when the think the system is running too hot for us to see. Go into edit mode within your question to post the pictures.

Was this answer helpful?

Score 2
Add a comment

Add your answer

guedes Jr will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 88