Released on September 19, 2014, this 4.7" screen iPhone is the smaller version of the iPhone 6 Plus.

2940 Questions View all

Signal goes from full to searching... and then requires me to activate

Hi, i have an iPhone 6 16GB Gold, The phone works fine for a short period of time, then looses signal and goes to searching... sometimes it will gather the network connection back, but on other occasions the phone deactivates it self and requires me to reactivate (which can be a pain as sometimes takes a long while for it to reactivate).

The sim card i am currently using in another iPhone (5s), and is working without fault, i have tried a different sim card in the iPhone 6 and that is doing the same thing.

Any ideas?

Thank you.

Forgot to mention, the screen has been previously replaced on this iPhone.

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

This is ridiculous... I'm Having the same problem and Apple don't have any solution. I paid a huge sum for it. Total loss because I'm in Liberia.

by

Add a comment

1 Answer

It sounds like the carrier/provider settings may not be correct in your phone.

Contact your provider and confirm the settings you find when the phone is activated are correct. Find them with the below instructions:

Settings > General > About > Note the following:

1. Network

2. Carrier

Your provider may ask for your devices IMEI, have that ready.

Is the phone unlocked?

Was this answer helpful?

Score 0

Comments:

Hi, thank you for your reply, carrier settings are correct, and the iPhone is on the EE Network, i have spoken to EE directly over the phone regarding this also, and have also tried turning auto carrier selection off, and keeping it on the EE network to no avail.

by

Add a comment

Add your answer

raz will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 90