Guides and support for various TV brands and styles.

1911 Questions View all

Why I have no power

I have no power on my vizio E320AR tv at all.I have 110v going in but nothing after that.There is a fuse in there but it is white so I cant see in it to see if it is blown or not

here are some pics of the board with the fuse in the right hand corner

Block Image

Block Image

Block Image

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Most Helpful Answer

dewser, at minimum you need a multimeter to check the fuse for continuity. If the fuse is okay, you will need at least the schematic to find out where the power goes next. Once you determined what is going on with the fuse, let us know.

Update

Loks like something is either getting hot or got hot. Check the secondary side. The coil looks somewhat ominous. It is possible the the IC's opposite the transformer have failed as well.

Block Image

Was this answer helpful?

Score 2

Comments:

with the multimeter what should it be set on and what should it read with the fuse

by

Whatever you do, make sure that you unplug your TV and do not touch any contacts:-). Use this video https://www.youtube.com/watch?v=znRHXQC9... for a quick introduction on how to test a fuse. We might be able to help you a bit better if you post some images of your power board etc. with your question. Use this guide to do so Adding images to an existing question

by

Add a comment

Add your answer

dewser will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 191