Model A1174 with 2 GHz Core Duo or Model A1207 with 2.16 or 2.33 GHz Core 2 Duo

275 Questions View all

Is the hard drive gone?

I have a I-mac G5 intel 20" with Snow Leopard os, I am getting a

flashing "?" with a folder at start up. I tried running off on the os

disk utility, but it does not see my drive. I tried a number things including using safe boot and zapping pram. Nothing works. I can boot off from an external hard drive that has Snow Leopard installed, but the mac still does not see the internal. Is the hard drive gone?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

You've tried everything I can think of except some thing like Tech Tools Pro or Drive Genius. Sounds pretty hopeless, sorry.

Was this answer helpful?

Score 0


Yeah, that is what I thought. I guess I was in denial. I appreciate the help.


Add a comment

Did you try running disk utility from the external drive? Have you jarred or moved your computer recently? Could the connection have come loose to the hard drive? If you don't have Tech tool Pro, you might try swapping the two drives you have, the internal and external, and see if the original drive is accessible from within the external case. If not, that confirms that the drive is bad.

That's all I can suggest. Good Luck!

Was this answer helpful?

Score 0
Add a comment

Add your answer

FreddieV will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 965