Released on September 19, 2014, this 5.5" screen iPhone is the larger version of the iPhone 6.

794 Questions View all

I am getting code (-18)

I replaced the screen with another LCD Digitizer on the I phone 6 plus. Kept giving error code 53 and hanging in the middle of the download. I read on forums to put original screen back on and then try to update. Now I am receiving code -18. There is no help for the minus (-18) on any help from Apple or google that I can find.

I have no firewalls

I have updated my computer

I have the correct data cable

I have cleared all cache/cookies

I have uninstalled and reinstalled I tunes

I have the latest updates on my computer and I tunes

I have done the same process on 2 different computers and come up with the same -18 code.

I have went back through the Iphone 6 plus and made sure all connections are secure

I have pressed the power but to release the power with the battery disconnected on each occasion

I am at a loss on what to do, I need some help.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Home button / home button cable are original and connected when doing the restore? Anything torn/broken?

Did you screw back the metal shield over the screen connectors and mixed up the screws in the process?

by

I have had others that have broke the flex cable by cracking and smashing it and a different home button has worked

by

The home button and logic board not matching should not lock down the phone to the iphone screen. People use new iphone buttons all the time and just don't have identity capability. There has to be a solution.

by

The computer fell off the motherboard. I tried to reattach it and put conductive glue on the cable but it did not work. Please give me a solution

by

The small motherboard on the flex cable of the button fell off during repair and I tried to put it back together, without any luck. I tried to scrape and glue the flex cable with conductive glue, and scraping. Still no go

by

Show 1 more comment

Add a comment

2 Answers

Chosen Solution

The original home button was damaged. I put the screws in the correct place

I put them exactly in the place that they went

Was this answer helpful?

Score 0

Comments:

I put another brand new home button because of the damage

by

Add a comment

My bet is on (missing the original home button) being the culprit. Put it back and try again.

Was this answer helpful?

Score 0

Comments:

I can't. It was torn in half on the flex cable

by

The home button itself or the cable that connects it from the screen to the board?

by

I can't. It was torn in half on the flex cable. What else can I do?

by

Nothing. No original home button = restore error. I'm speculating, but if you have abother phone, give it a shot by connecting an original screen with home button then restore. Would this solve it? Although I highly doubt it. Home button and logic board should be matching.

by

Add a comment

Add your answer

Shannon Bradford will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 7

Past 30 Days: 154

All Time: 6,095