Skip to main content

Does not boot, PMU reset doesn't do anything, what's the PMURST for?

First here is what happened: I had installed Linux and that was working well until I shut it down and it wouldn't turn on any more. Now it's dead in that sense that there isn't even a chime when I press the power button.

I tried a PMU reset, removed extra RAM, removed the battery, etc but no joy.

Previously, when doing a PMU reset (Shift, Option, CTRL, Power and simultaneous release) I noticed the led on the power plug would flicker. Now it doesn't do anything. I've tried with and without battery (which doesn't have the 5 leds lit - is that normal?).

Now I've discovered a couple of pins under the extra RAM on the back of the machine. They're labelled PMURST, GND, +2.5V, +3.3V, +5V. Has anyone ever used these before to do a PMU reset. I've tried connecting each of them with the PMURST with and without power but still no chimes and screen stays black.

Answered! View the answer I have this problem too

Is this a good question?

Score -1
Add a comment

3 Answers

Chosen Solution

Hi! Are you saying the light on the AC adapter plug is dark, or that it is solid green and no longer flickering? If it's dark, that means you either have a bad AC adapter (power cord) or that the DC-in (the plug inside the computer) is bad and needs to be replaced.

When you power on, do you get any noises, sounds, rumblings at all, or is it completely dead? If you do get some signs of life, have you tried booting into option mode to see if that works (hold down the option key while powering on)?

What I've always known as the PMU reset involves holding down the power button for about 10 seconds while the computer is off and connected to AC power. The fan should turn on, then you should hear a solid tone. Of course, if you AC adapter light is dark and power is not getting to the computer, this won't work.

Anyway, let me know if any of this helps. If you don't get a light on the AC adapter plug, try twisting it in its socket until it turns green, and then try powering it on.

I don't think a PMU reset is necessarily the answer, especially if the AC adapter light is dark. If it's dark, you're dealing with a hardware issue.

Was this answer helpful?

Score 0
Add a comment
Most Helpful Answer

Just for completeness. I opened up the powerbook and found the power switch socket had become loose. So I soldered it back on and everything is back to good!

Sorry for wasting your time...

Was this answer helpful?

Score 3

1 Comment:

Accept your own answer. It can be archived and used to help someone else.


Add a comment

I'm sorry my post wasn't clearer. The light is green, it's green all the time. Which now I'm beginning to think is a bit weird. Because I left it out for a while without AC and still it's not trying to charge the battery.

I tried the 10 seconds method too but nothing happens. It's very dead..

Was this answer helpful?

Score 0
Add a comment

Add your answer

miiimooo will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 2,212