Model A1311 / Mid 2010 / 3.06 & 3.2 GHz Core i3 or 3.6 GHz Core i5 Processor

239 Questions View all

Will not power on, hear a slight fan sound but then nothing.

The machine was running, when I can back to my desk the screen was blank. I tried to power it on but nothing happened. Checked all the cords and removed all external devices. How do I test to see if it's the power supply or something else?

I replaced the power supply as instructed, but the machine still will not start. It sounds a little different when tiring to start, I hear what sounds like the HD spinning. Checked the LED test lights and still only the #1 is lit up.

Thanks

Ian

Answered! View the answer I have this problem too

Is this a good question?

Score 1

Comments:

OK, I replaced the power supply but no difference. Maybe the hard drive sounds like its running?

by

Add a comment

1 Answer

Chosen Solution

You need to take a look at the diagnostic LEDs. Take a look at this question for how to interpret them and location: Where are the diagnostic led's on this model's logic board

Was this answer helpful?

Score 2

Comments:

Try using this guide but not disconnecting the cables yet. Just lean the display forward and see if you can see the LEDs. iMac Intel 21.5" EMC 2389 Display Replacement

by

Do I remove the display first

by

I can not disconnect the LCD thermal sensor cable connector from its socket on the logic board.Does not want to pull off. Am I missing something?

by

I got the display cable off. Plugged the computer in. The only LED light that comes on is the #1. It stays on but that's it. Pressing the power button results in what sounds like the hard drive trying to start up. A couple of clicks then nothing.

by

Replace the power supply. Here's how: iMac Intel 21.5" EMC 2389 Power Supply Replacement Here's the part: iMac Intel 21.5" Power Supply

by

Show 2 more comments

Add a comment

Add your answer

Ian Hurley will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 211