Skip to main content

2.5 GHz dual-core Intel Core i5 processor (Turbo Boost up to 3.1 GHz) with 3 MB shared L3 cache.

266 Questions View all

Apple Hardware Test Error: 4SNS/C0000008:Ts0P--124

After running Apple Hardware Test I got the error code 4SNS/C0000008:Ts0P--124. Some the symptoms I observe is that the computer runs very slow and the fans are always running at high speed from the moment I start the laptop. Anyone knows what this means?

Block Image

Update (04/27/2015)

Okay oldturkey03, I posted an image of the inside of my Macbook 13" retina late 2012 in my first post. What's circled in red is the SSD tray that has the solid state drive. What's circled in yellow is where I believe the palm rest temp sensor should be located from reading your description. Please correct me if I'm wrong.

Answered! View the answer I have this problem too

Is this a good question?

Score 1

I have the Same issue on the same model. Did you solve it? Is the sensor there in the picture?


Yes, that's the board where the sensor is located. It's part of the trackpad. Follow this IFIXIT guide: MacBook Pro 13" Retina Display Late 2012 Trackpad Replacement


Ts0P could be:


Trackpad Flex

Camera (in some models)

Trackpad flex connector (logicboard)


Add a comment

3 Answers

Chosen Solution

Jstervil, the problem is most likely related to the sensor of the Ts0P Palm Rest Temp sensor. The palm rest sensor is located on the hard drive cable. It is under the hard drive and up against the front edge of the machine. It may be a bad sensor or your may after corrosion, liquid spill etc. You may want to consider to download and install this Temperature Gauge Pro. It should help show you what your sensors are telling you.

Was this answer helpful?

Score 3


I still can not find the palm rest temp sensor. I read somewhere that it is built in with the track pad ribbon cable, is this true? Also is there anyway I can take a picture of the inside of my mac and upload it here.


under these conditions it is impossible to install any software


Add a comment
Most Helpful Answer

I had this problem too, it is caused by the temperature sensor on the trackpad cable not being detected. I tried replacing the trackpad cable, no difference. I then read about a relationship between this sensor and the iSight camera, so I tried powering up without the camera connected (the cable came right away from the connector when trying to pull it out...) and the MacBook Pro (early 2011) now boots fine. Try it!!

Was this answer helpful?

Score 5


did you replace the iSight cable?


Got this problem and solved it .

First of all sorry for week english language , im from iran .

Then . I upgraded my A1278 early 2011 ( 2 × 8gb ram + ssd + hdd cady using my old hdd ).

When i used to install the caddy , unfortunately isight cable failed but the socket remained in . Now after long and doing everything i could , i thought it may be the problem . Just opened the bottom of the macbook , took the socket out , and that's it . Problem solved . Wish it helps you all .

Love you all .



Add a comment

I fixed the problem. I replaced the trackpad ribbon cable and everything worked fine.

Was this answer helpful?

Score 2


I have this problem also with My MacBook Pro early 2011, 1278. Everything boots up but is very slow loading. Fans is running loud. Replaced the heat sink, Trackpad, Fan and I still get the same error code.. Apple Hardware Test Error: 4SNS/C0000008:Ts0P--124. Now what? Could be left. Help


Edith, I have the same issue and error as you with a 2011 Macbook Air. Did you resolve your issue?


No I did not. I changed the Palm rest sensor and downloaded the software suggested. Also replaced the track pad & cable, HDD & cable. None of this worked. Apple wouldn’t repair it because I replaced part. So it sits in the closet. I’m thinking maybe it’s the board.


Add a comment

Add your answer

Jstervil will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 27

All Time: 7,761